Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Toshiba Satellite which has a Realtek RTL8187B Wireless 802.11b/g 54Mbps USB 2.0 Network Adapter. Whenever I start a Virtual Machine in Virtualbox my wireless connection stops working. It is a known bug from very early versions of Virtual Box but I can't seem to find a fix for it. I'm sure Virtualbox used to work. I'd really appreciate some help.


share|improve this question

From what you write, it sounds as if VirtualBox is taking over the USB networking device, meaning that the host OS can't use it any more. Use the Devices menu to de-select the USB network adapter and all should be well.

share|improve this answer
Hi, thanks for your reply. Although the device name says USB in it, it is internal. Also, I am using Windows 7 64bit. I still want to be able to use networking in Virtualbox. – Sam Jun 30 '11 at 4:55
If it says USB it may be USB, even if it's internal--I have seen setups like that. And what you should do in most cases with VB is use NAT via the host OS. – CarlF Jun 30 '11 at 22:56

What version of Virtual Box are you using.

Check your network adapter in virtual box and let us know how it's getting it's connection.

You may want to try and fully uninstall Virtual Box and try reinstalling it as it will remove the virtual networking adapter and be reinstalled.

share|improve this answer
I am using the latest version of virtualbox. I have tried reinstalling and that hasn't worked. The connection in Virtualbox says that it is getting the connection from VirtualBox Host-Only Network. – Sam Jun 30 '11 at 4:57

The reason for the slow networking is a bad auto-detection of the network settings in Windows. You don't want Windows to automatically detect settings after Virtualbox was installed. Go to Control Panel => Internet Properties => Connections tab => LAN settings, and make sure all of the checkboxes are UNchecked. After I did this and rebooted, the difference was night and day!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .