Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My system (Debian squeeze) uses anti-aliasing for fonts, which is fine for the most part. However, I would like to disable it for terminal fonts in xterm and urxvt (rxvt-unicode), and can't get that to work.

I tried using antialias=false, like explained e.g. in the urxvt man page (search for "antialias"), but it does not have any effect:

urxvt -fn "xft:Deja Vu Sans Mono:pixelsize=10:antialias=false"

I get exactly the same font rendering, no matter if I use antialias=true or false. The font face and size I specify do have an effect, so urxvt apparently processes the option.

Same result with xterm (using -fa), or when putting Xft*antialias: false into my X resources (as proposed in How can I turn off font-antialiasing only for gnome-terminal, but not for other applications?).

What am I doing wrong? Is there some other setting?

Edit:

Just found out that I can disable anti-aliasing in /etc/fonts/local.conf:

<match target="font">
  <edit name="antialias" mode="assign">
    <bool>false</bool>
  </edit>
</match>

Still, I don't understand why antialias=false is not respected in a font spec.

share|improve this question

2 Answers 2

Usually xterm does not apply antialiasing to fonts. However, I think some windowmanagers like compiz generally apply antialias to windows, hence your problem would be your window manager, not your terminal emulator. Try checking your window manager for antialiasing and try disabling it.

share|improve this answer
    
I don't think a window manager can apply antialiasing - antialiasing must happen during rasterization. The window manager only gets the rasterized result, by then it's too late. Do you have any sources for your claim? –  sleske Apr 30 at 12:22
    
I'm sure I had one back then. After three years, this is probably worthless. Antialiasing needn't happen during rasterization. –  user1129682 May 2 at 20:53

xterm actually work with font antialiasing like below.

~/.Xdefaults

!xterm font antialiasing variant
xterm*faceName: DejaVu Sans Mono:size=10:antialias=true
xterm*font: 7x13
!rxvt-unicode fontantialiasing variant
URxvt*font: xft:DejaVu Sans Mono:pixelsize=12:antialias=true:hinting=true
URxvt*boldFont: xft:DejaVu Sans Mono:bold:pixelsize=12:antialias=true:hinting=true

As I investigated simple rxvt (without unicode) doesn't support font antialiasing. The reason why I prefer xterm today (2015) is lesser amount of memory consumed by xterm when is opened then urxvt. Rxvt consumes even lesser amount of memory then xterm, but it doesn't support font antialiasing.

share|improve this answer
    
This does not answer the question - the question is how to disable antialiasing, not how to enable it. –  sleske Apr 30 at 12:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.