Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to convert my external hard drive from fat32 to ntfs. If possible, I want to avoid losing the data or having transfer it off and back on and formatting ( I have about 400gb of data).

I am using windows 7.

[The hard drive is a samsung story 1.5tb drive] It arrived in FAT32 but I did not check this and began using it. For the past year I have been using it without any problems. Only recently had I started to deal with large files and suddenly I noticed that it is not ntfs and that fat32 has a 4gb limit.

I have tried:

1) opening cmd as administrator and doing a conversion there e.g: convert E:/ fs/ntfs This failed. It said messages about the drive being in use and asked me if i wanted to kill these connection i entered Y and it would not convert.

2) I ran chkdsk everything was fine. Tried again as above.. failed to convert to ntfs.

3) I searched for third software to do this - i have in the past used 'partition magic' to do this but i noticed that this program is very old so i found 'EASEUS partition master' it was not able to convert it.

4) I restarted in safemode command prompt and ran the convert E:/ fs/ntfs command from there everything seemed to go right up to the last minute and then it failed to convert.

Are there any other methods other then the obious "move the data off the drive format and place it back on" route.

share|improve this question
    
"Failed to convert" tells absolutely nothing to us. There can be 100 different error messages there. Also, make sure you are entering the command correctly. It's convert E: /fs:ntfs, not convert E:/ fs/ntfs. –  grawity Jun 29 '11 at 18:13
1  
For all the trouble you're going through to convert this, you could have simply moved the data somewhere else, reformatted, and copied it back. Not only would it take less time than a partition conversion, but you should have a backup anyway before attempting the conversion in the first place. What you're attempting is inherently risky. –  afrazier Jun 29 '11 at 20:14
    
Not an option with 400GB of data. Thanks anyway –  Tom B Jul 2 '11 at 16:03

4 Answers 4

up vote 1 down vote accepted

Thanks for the responses guys! But I fixed the issue myself in the end...

What I did was use this command:

convert E:/ fs:ntfs /NoSecurity /X

This action disabled the UAC by disabling security and allowing all user access. /X dismounted the drive before conversion. It attempted the conversion. Chkdsk found errors on the drive.

I then ran this command:

chkdsk E:/ /F

(/F fixes any errors on the drive automatically)

It worked and fixed two corrupt file errors in insignificant files.

I then finally did the original command again:

convert E:/ fs:ntfs /NoSecurity /X

Conversion was successful this time and took about 20 minutes in total.

I can't begin to imagine how long it would have taken to copy 400GB from the drive via USB, format the drive and then put the data back - I guess DAYS!

Thanks again for your responses; I hope someone finds this useful in the future when trying to convert an external hard drive from FAT32 to NTFS without losing data.

share|improve this answer

Partition Wizard supposedly does this. Haven't tried it myself though.

share|improve this answer

I would try three things:

  1. Easiest is to try converting it on an XP computer if you have access to one.
  2. Even when running things as an administrator, I have seen UAC get in the way of a few things, so I would turn of UAC, and then try again. To avoid this, is why I mentioned step 1.
  3. If it is not already a primary partition, I would try to make it one first.
share|improve this answer
    
Converting to XP not an option. Thanks anyway. –  Tom B Jul 2 '11 at 16:02
    
@Tom B I meant "on" (as in just plugging it into), not to...but that is not a problem. That was just so yo uwould not have to turn off the UAC. Turn off UAC, then try deleting in with the Windows partition manager, or even diskpart.exe. After it is deleted, you probably be able to recreate and format it with no problems. –  KCotreau Jul 2 '11 at 16:07

You should get this piece of software called Partition Master. Format the drive you need then when you hit apply you need to restart and it will boot into it's program and format it. it always works for me. Also you will need to restart twice, just wanted to warn you before you freak out.

share|improve this answer
    
As I said in my question I already tried partition master. –  Tom B Jul 2 '11 at 16:02
    
Please note I wanted to 'convert' the drive not format and lose valuable data, I also stated in my original question that I had tried similar software. Thanks for the response though! –  Tom B Jul 2 '11 at 16:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.