Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My OS X Tiger machine's browsers often don't work. Usually the page just times out. If I clear the cache, then often it will work once, then fail again. Sites I view frequently usually fail to load ever, and sites I've never visited usually work fine. Sites that require cookies, logging in, etc (like SuperUser) never work at all. This has been ongoing for ~ a year. It does this with Safari, IE, Firefox, and Camino. I've tried making new accounts, but new ones also fail. It fails with both a WiFi and an ethernet connection. Safari will even show me a preview of the current page using its new preview page, but when it attempts to load the whole page it times out. My XP and Ubuntu boxes work like a charm. I am ready to reformat/reinstall OS X. Anyone have any ideas?

Here is a traceroute that always works:

iBook:~ test$ traceroute www.google.com
traceroute: Warning: www.google.com has multiple addresses; using to www.l.google.com (, 64 hops max, 40 byte packets
 1 (  3.004 ms  1.638 ms  1.542 ms
 2 (  30.518 ms  28.308 ms  28.549 ms
 3  so-0-1-0-0.res-core-rtr1.verizon-gni.net (  27.642 ms  27.590 ms  33.804 ms
 4  so-6-0-0-0.lcc1-res-bb-rtr1-re1.verizon-gni.net (  26.062 ms  36.629 ms  25.779 ms
 5  0.so-4-1-0.xl3.iad8.alter.net (  27.232 ms  35.196 ms  28.048 ms 6  0.xe-10-0-0.br1.iad8.alter.net (  28.452 ms 0.xe-8-0-0.br1.iad8.alter.net (  35.639 ms 0.xe-9-0-0.br1.iad8.alter.net (  27.341 ms
 7  te-10-1-0.edge1.washington4.level3.net (  29.582 ms te-4-0-0.edge1.washington4.level3.net (  26.317 ms  26.238 ms
 8  ae-3-89.edge1.washington1.level3.net (  27.279 ms ae-1-69.edge1.washington1.level3.net (  29.985 ms ae-4-99.edge1.washington1.level3.net (  36.367 ms
 9  google-inc.edge1.washington1.level3.net (  110.773 ms google-inc.edge1.washington1.level3.net (  49.345 ms google-inc.edge1.washington1.level3.net (  51.936 ms
10 (  30.932 ms  30.541 ms  30.300 ms
11 (  29.929 ms  30.641 ms  30.614 ms
12 (  29.031 ms (  40.960 ms (  103.046 ms
13  yo-in-f103.google.com (  30.472 ms  31.197 ms  32.809 ms

And here is a traceroute that always fails:

iBook:~ test$ traceroute www.reddit.com
traceroute: Warning: www.reddit.com has multiple addresses; using
traceroute to reddit.com.edgesuite.net (, 64 hops max, 40 byte packets
 1 (  2.542 ms  3.832 ms  1.630 ms
 2 (  38.817 ms  31.989 ms  28.636 ms
 3  so-0-1-0-0.res-core-rtr1.verizon-gni.net (  29.174 ms  31.008 ms  28.681 ms
 4  so-6-0-0-0.lcc1-res-bb-rtr1-re1.verizon-gni.net (  43.241 ms  27.859 ms  25.639 ms
 5  0.so-6-1-0.xl3.iad8.alter.net (  27.223 ms 0.so-4-1-0.xl3.iad8.alter.net (  26.414 ms  25.986 ms
 6  0.xe-8-0-0.br1.iad8.alter.net (  29.308 ms 0.xe-10-0-0.br1.iad8.alter.net (  27.816 ms  27.910 ms
 7 (  26.439 ms  26.810 ms  28.325 ms
 8 (  27.719 ms  26.456 ms  107.241 ms

And here is a traceroute of reddit from my working XP machine:

C:\Documents and Settings\Compaq_Administrator>tracert www.reddit.com

Tracing route to a659.b.akamai.net []
over a maximum of 30 hops:

  1     1 ms    <1 ms    <1 ms
  2    29 ms    40 ms    39 ms
  3    25 ms    25 ms    24 ms  so-0-1-0-0.RES-CORE-RTR1.verizon-gni.net []
  4    25 ms    24 ms    27 ms  so-6-0-0-0.LCC1-RES-BB-RTR1-RE1.verizon-gni.net[]
  5    24 ms    25 ms    25 ms  so-3-0-0-0.RES-SVCS-RTR1.verizon-gni.net []
  6    25 ms    25 ms    24 ms  a199-45-62-11.deploy.akamaitechnologies.com []

Trace complete.

Also, if I type in the address bar, the web browser loads Google. But if I type in the address bar, Safari/Camino/etc report "Invalid URL - The requested URL "/", is invalid."

share|improve this question
run a traceroute on a site and post results –  John T Aug 27 '09 at 1:40
Hmm, interesting - I'm not familiar with traceroute. –  Greg Aug 27 '09 at 1:58

2 Answers 2

You can't read too much these days into traceroute results - end networks will often filter the various packets that traceroute relies upon. Even tcptraceroute (a useful diagnostic tool, as it gets closer to testing the actual thing you want to test - the path of a TCP connection) will suffer if the ICMP error reply packets are filtered.

That said, one obvious thing in the results you give is that your www.reddit.com resolved to a different IP address in each example. So you might first double-check that you're using the same, correct DNS server for all lookups.

Next, what sort of failure are you actually experiencing in the browser?

  • complete failure to connect (immediate failure.)
  • connection timed out, nothing at all?
  • connection timed out, part of the page loads but some things don't

You mention about pages that require logging in - that could be a clue, as that suggests more data being sent to the site than a simple HTTP request.

You might have some NAT incompatibilities, some localised firewall issues, or something like that. It might not actually be OS X's TCP stack at fault, it could just be some of the TCP flags that it's setting that the other OSs aren't, and there's plenty of candidates (SACK, path MTU discovery, windows scaling, to name three.)

share|improve this answer
up vote 0 down vote accepted

My iBook works now. I changed the router and all is good. I had an old Zyxel 802.11B router; I just got FIOS now and it worked immediately with the new router. Apparently the Zyxel works poorly with iBooks :(

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.