Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to be able to access my Lacie 2Big network drive in Windows 7 Explorer. I have a machine with Windows 7 Home and one with Windows 7 Professional.

Neither Windows 7, home or pro, can access the drive. The Windows 7 Home machine displays the drive in its Explorer, with the capacity, but on clicking the icon, I get another window, blank with the busy pointer which does not eventually stop.

The drive is working perfectly. How do I know this? Because I can access it with no problems on my Apple Mac, Windows XP home and Ubuntu machines on the same network as the Windows 7 machines. Except for the Windows XP home machine that required Lacie ethernet agent program, the Mac and the Ubuntu machines needed no setup, the drive appeared like any other drive.

So my 2 questions:

  1. Is it possible to access a network share drive, e.g. a NAS like Lacie 2big in Windows 7 Home Premium and Windows 7 Professional. If so how?

  2. I read on Microsoft's own forums and elsewhere that network sharing drives, e.g. via SambaSMB is NOT possible on Windows 7 Home. Is this true?

This question is a more comprehensive re-write of my earlier question: Windows 7 / TCP/IP network share guide - looking for to resolve failure to mount lacie network drive but works on XP,Linux,Mac.

...where I haven't received a solving answer, and I have tried to find a solution myself. Lacie themselves haven't offered a definitive solving answer either, but I suspect it's not just their drives but SMB/network share/NAS in general...

This is utterly pathetic that Windows 7 home cannot access something as simple as a network drive, especially given that Windows XP home can.

My research so far:

Apparently it is possible on Windows 7 Professional, via the Local Security Policy, only on Windows 7 Professional, not Windows 7 Home:

Another solution offered is editing the registry, doesn't look promising to me, fiddly and not guaranteed, hard to produce a complete solution I think, given that everyone's registry can vary. Registry key edit solutons:

My lacie ticket is:

Also related:

share|improve this question
    
I would check in network an sharing center, be sure the network connection is not set to "public" but to "Home". There are some other settings in there you may want to check also. –  Moab Sep 17 '10 at 19:35
    
What model Lacie 2Big exactly? –  KCotreau Jun 30 '11 at 2:00
    
@KCotreau Lacie 2big Network, 2 x 1TB raid drives configured as a 1TB RAID drive, gigabit ethernet, purchased in 2008. The model is not on sale now, so the closest equivalent is lacie.com/uk/products/product.htm?id=10477 –  therobyouknow Jun 30 '11 at 8:02

5 Answers 5

(edit - see accepted answer)This should be the solution but it's not, it did work once but no thereafter. To answer my question, YES (well, once!) it is possible to map/mount a network drive (presumably by Samba/SMB) as a drive letter in Windows 7 HOME (and likely same procedure for Professional, also, I will update).

It should be a simple standard procedure, once you know, and here's how.

Pre-requisite: for your network drive/NAS drive brand, you may require a utiliy to be installed first. With Lacie drives, such a utility is the Lacie Ethernet Agent/Lacie Ethernet Assistant. This application should be running in your system tray all the time, once installed.

1) Start Menu, Select the Computer option to open the Computer Explorer Window. On the second-level drop-down menu options, find the 'Map Network Drive' and select it:

http://i52.tinypic.com/2j3mxrs.png

2) Select an available/free drive letter (in my case Z:) and enter the server and path, in my case this is \Lacie-2big\lacie-2big-raid

http://i54.tinypic.com/2nlhh10.png

3) DONE! An explorer window should open showing the contents of your drive.

http://i54.tinypic.com/iwpz0k.png

share|improve this answer

I would try following things to determine the real problem.

Try connecting your disk on another windows 7 (other computer). See if the problem persists. If so, The problem is with the disk or firmware. Check the lacie forums or the official lacie support channels. Or contact your local store where you bought the disk.

If the problem is not solved. Verify if you can connect to your disk by using a ping, and check if you can connect to the web interface. Verify all options in the administration interface of the NAS.

If you suspect your windows system files are corrupt, maybe try a "sfc /scannow" on the command prompt (you must be administrator).

share|improve this answer
    
Lacie are very supportive and have provided a solution - which is one of the things you recommend. I'll post the answer here as an answer to my own question - the answer they gave when I get some more time. +1 for your logical steps to diagnose the problem. –  therobyouknow Jun 8 '11 at 21:26
up vote 1 down vote accepted

I'm going to unaccept my own answer ( Looking for definitive answer to accessing a network drive/NAS/SMB drive via Windows 7 HOME and Windows 7 Professional. Is it possible and how? ) because while this should work (well it's the standard method that Windows offers, being an option on the Computer Explorer menu no?), it DOESN'T work all the time.

It doesn't work all the time, but it has done, it seems to be intermittent, well actually not working at all now, because after following the steps I get another, blank, window with the Windows busy wheel. It should work all the time. Windows seems to go into a "sulk" if you've ticked the box to say "mount on startup" when the drive is not switched on when it tries to find it. It's as if it says: "well I'm supposed to mount this drive on startup, but I can't find it, so even it it does become visible on the network later, I'm going to be rigid and stick with my original finding of it not being there". :(

I'm so annoyed. There is not a solving answer to this question that works 100% of the time.

FACT IS: Mapping (and mounting) a standard common network/NAS drive should be as simple as just plugging in a USB drive.

I WON'T GIVE UP Next steps will be:

  • Analyse the packets exhanged for connecting successfully with XP compared to those with unsuccessful attempt in Windows 7, using Wireshark: Looking for tool to show IP packets (and do analysis) sent/received from/to my machine (want to debug why can't mount network drive)

  • Another thing to try will be: uninstall Norton Internet Security completely from the Windows 7 home machine, turn off Windows firewall and attempt to mount the drive. If works, start to turn things back on, one by one, if possible and see what causes the problem, if it is Norton, for example, report this on their forums.

    UPDATE: I've completely uninstalled Norton, and completely turned off all of Windows Firewall. But still unsuccessful at connecting the the NAS. Then I connected the NAS directly to the computer via a network cable, i.e. no router in between, still unsuccessful.

UPDATE 2 It strangely started working. Strange because it suddenly started working and that it is not clear to me what particularly I needed to do. I think that settings for sending unencrypted password being enabled are significant as I had to do this for my desktop Windows 7 pro 64bit machine at work to access a samba share on a CentOS Linux machine.

share|improve this answer

If you can access it from Windows XP, but not Windows 7, it sounds like it could be a firewall issue. The firewall in Windows 7 is more locked down (OK, relatively speaking). Turn off your firewall and test. If that works, post back, and I will help you figure out where to go from there.

To answer your question 1 (not sure about 2):

  1. It really is a function of the NAS and its ability to share out in a form that Microsoft understands, and clearly it does if XP can read it. From there, you should just be able to browse to it provided nothing is blocking it like a firewall.

For the record, when you do browse to a share in Windows, all the ones I just tested do read 0 bytes, but once you drill down into them, they show the byte count for the sub-folders.

share|improve this answer
    
Of course, I don't just have bare Windows, I have an internet security package, Norton Internet Security. So when I go to the Windows Firewall section of the standard Windows Control Panel, it says this is under control of Norton, and all the options aren't clickable. Going into Norton there is all this stuff about smart firewalls and intrusion ports, I've tried turning off as much as I can but it makes no difference. It would be nice if there was just a big switch in Norton, marked "OFF" for the purposes of your debugging my setup. Most of the time I want to keep it on. –  therobyouknow Jun 30 '11 at 19:44
    
So it seems impossible to just turn off everything easily, searching the forums doesnt reveal much, much the same as what is on offer in the settings.The only other option would be to uninstall Norton. I don't think that would help, given that the Windows XP machine that can access the drive no problems also runs the same Norton. What I really need is: something to say let traffic in and out on this/these IP addresses and ports and for me to know what the numbers of these addresses and ports are, exactly, for my drive to be definately accessible. Surely I'm not asking too much? –  therobyouknow Jun 30 '11 at 19:47
    
definitely not definately. –  therobyouknow Jul 1 '11 at 8:55

Make sure that you have selected "Use NetBIOS over TCP/IP" in IPv4 Properties → Advanced Options. The "TCP/IP NetBIOS Helper" and "Distributed Link Tracking Client" services must also be running.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.