Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a problem that has me totally stumped, and I'm hoping someone here has some ideas that might help me.

I have:

  • A Dell computer running Windows XP
  • A Linksys AG241 ADSL modem
  • A Netgear WGR614 wireless switch

Until recently I had the Dell and the Netgear plugged into two network ports on the Linksys and everything worked fine. The Dell could browse the internet, and my iPhone could too via wireless. Then it stopped working for no apparent reason, and I have no idea why.

Things I have tried:

  1. Plugged my Lenovo Win7 laptop into the DSL modem -- can browse the internet no worries
  2. Plugged Dell into the Netgear -- can see it and configure it fine
  3. Plugged Dell into Linksys -- can't see it. The network port light on the front of the Linksys doesn't light up.
  4. Plugged Netgear into the Linksys -- can't see it. The network port light on the front of the Linksys doesn't light up.

Point 1 tells me that the Linksys modem is fine. Point 2 tells me that the Dell computer is fine. But when I plug the Dell into the Linksys it doesn't work (#3).

I am completely stumped and don't know what to do next.

share|improve this question
    
so you can only plug one device into your DSL modem? could it be NAT is off? i think that might be what'd happen if NAT is off. –  barlop Jun 30 '11 at 1:33
    
When you have scenarios 3 or 4, can you ping 8.8.8.8? –  KCotreau Jun 30 '11 at 2:03
    
Both the modem and the wireless switch have 4 ethernet ports on the back. In scenarios 3 and 4 the lights on the modem indicating a plugged-in network cable don't light up -- it doesn't physically recognise the connection. I've tried switching the cables around - no difference. –  Stewart Johnson Jun 30 '11 at 3:19
    
New datapoint: now when I plug the Dell into the linksys, Windows is showing the connection being plugged-in and then unplugged about once every two seconds. (I'm not touching anything.) My Lenovo laptop that I'm using right now is also plugged into the modem, and internet access is fine. I've switched over the cables and the ports, and I see the same behaviour. I am COMPLETELY flummoxed. –  Stewart Johnson Jun 30 '11 at 3:22
    
@KCotreau: When I ping 8.8.8.8 it says "Hardware Error". Earlier today I suspected the old network card was dead, so I bought a brand new one and installed it this morning. –  Stewart Johnson Jun 30 '11 at 3:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.