Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been using Lexmark X3650 All-In-One on my Windows Vista Desktop PC for a year without problem. Yesterday, I was prompted to plug in the USB from the printer and after that I got errors: "The USB device has malfunctioned." ,"The unknown device has been installed unsuccessfully.". Then, the printer just stoped responding. I have uninstalled the driver from Device Manager and software (using Lexmark's clean utility), rebooted, reinstalled, same thing, tried different ports/cable. Vista displays these two errors stated above immediately upon plug in. Please help me!

share|improve this question

2 Answers 2

This sounds suspiciously like the USB interface on your printer has given up the magic smoke that makes it work.

Assuming that other USB devices work in these ports then your computer should be fine. The last thing you could try is to see if the printer will work on another computer, if you get the same error then I'm am afraid that chances are your printer has died.

If, on the other hand, the printer works fine then there is potentially some kind of driver corruption that will need to be looked in to.

share|improve this answer

When you connect your printer to the computer, if the computer takes it as an unknown device, uninstall the printer and disconnect. And then disconnect other USB devices except keyboard and mouse. Go to Start>Run>type DEVMGMT.MSC to open Device Manager. Click the (+) arrow next to the Universal Serial Bus Controllers, and uninstall all the USB ports in the list. Reboot and the computer should reinstall every USB ports. Then try to connect your printer and install the latest driver for your X3650 again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.