Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Windows 7 Ultimate on a Windows network. My default settings is Danish locale, Danish keyboardlayout, but English system language. I only have Danish keyboard layout installed (in Text Services and Input Languages).

However, at the login screen I can choose Danish and English, but whatever I choose Windows 7 changes system language (and keyboard layout!) to English (United States). Since this is a per-App setting I must change the language setting (language bar in the taskbar)

Where can this be changed system wide and permament?

share|improve this question

5 Answers 5

Go into Control Panel>Region and Languages>Keyboards and Languages tab>Change Keyboards, and remove the ones you don't want.

share|improve this answer

Open the Region and Languages in the Control Panel and do this:

Click the Keyboards and Languages tab and click Change keyboards...

enter image description here

From here you can either change the Default input language to Danish.

enter image description here

Or you can completely remove the US Keyboard.

enter image description here

Doing either one of these should result in you being able to use only the Danish keyboard instead of having to change it per-app as it makes it the default system-wide.

share|improve this answer
    
KCotreau, Thiago M: If it just was that simple ... As mentioned, I already have ONLY Danish Keyboard installed. So my setup is as shown by Thiago above, but ONLY Danish keyboard. Anyway, when rebooting, the language settings are EN and so is the keyboard. ChrisF, sorry about the emphasis in the original post - frustration... –  Hans Jul 1 '11 at 10:57
    
I THINK I SOLVED IT! I changed the default language to English (United States) and chose the Danish keyboard to go with that. Seems to work so far. –  Hans Jul 4 '11 at 15:03
1  
Uh ... It tricked me. Windows 7 still manages to sneek in a US keyboard layout in there somehow, and sets this as the default! Again, I beleive I have purged all mentioning of US keyboards in my "Text Services and Input Languages" setting, but it is still there! –  Hans Jul 4 '11 at 15:11
    
I found the solution here in the first comment: answers.microsoft.com/en-us/windows/forum/windows_xp-desktop/… –  atraudes Jun 6 '12 at 17:37

I found a solution that worked for me. The problem was that I only had Dvorak installed under Installed Services, and since the computer's locale was set to US, it kept defaulting to that. Once I added US to Installed Services and set Dvorak as the "Default input language", it started behaving.

In your case, changing the system locale to Danish may remedy your issue. In the Region and Language window (first pictured by Thiago), click the Administrative tab, then click "Change system locale" and choose the appropriate selection from the list.

I don't know if this is a desirable fix for you, but there you go. I really wish this wasn't so complicated; I don't have this problem on my Mac... ;-)

share|improve this answer

The best solution (assuming you want to have access to more than one keyboard, which I did) is to go into the Control Panel, Keyboards and Languages/advanced settings.

And change the keyboard shortcut for switching keyboards from Ctrl/Shift to none!

All along, I, too thought it was changing from Eng to Fr on a "random" basis. But it wasn't random at all: I always use keyboard shortcuts, and one of my favorites is Ctrl+Shift+Tab for moving to the previous tab in Chrome.

Stumbled on the shortcut conflict when checking out someone else's suggestion of going into Control Panel. That's when I saw the problem. Once I turned off the keyboard shortcut for changing languages (no biggy) I've never again had the problem. Random or otherwise! Mystery solved!

share|improve this answer

This is a the most annoying bug and it still happens to a genuine brand new HP computer with
Windows 7 Buisness OEM but my issue is also related to 'MS Word 2003' not changing keyboard layout (could not Apostrophe properly )

I use 2 keyboard layouts: US-International and French

I found these solutions that worked for me and some that seems like your issue:

METHOD 1

In MS WORD 2003 [“] and apostrophes [‘] would not display until another key was pressed.
Then this key and the quote or apostrophe would appear on the screen.

Checking in the keyboard settings the system was set to United States-International and French for it’s keyboard layout.

Change your keyboard layout to another US layout and removed the United States-International keyboard layout.

After pressing OK, I tested it on a Word Document and the issue still remained.

But after rebooting the system it went back to normal and I could use apostrophes and quotation marks as usual.

Suggestions (if it fails):
Try to change your Windows local language Unicode just to see how it behave.
Another suggestion related to application language switching issues is to change the hotkey combination that switch the keyboard layout.
Also in Word turn off when configuring Microsoft Word 'Smart Quotes' option.

METHOD 2

Before changing registry values I recommend making a restore point or a registry backup.
Use it at your own risk
To change the keyboard layout manually you need to change the keyboard layouts\preload\
Registry key in the Registry:

Press Start> type Regedit.exe

In the registry locate this key:

HKEY_CURRENT_USER\ Keyboard Layout\Preload\1

You will need to edit the Registry Key , change the string key "1" value setting to the "ID Language code" number listed below next to the keyboard layout name you want.

Close Regedit.exe

Restart Computer

Note: Preload\2 is used if you want to be able to switch between two keyboard layouts.

Find the ID language code here below:

00000402="bg"
00000404="ch"
00000405="cz"
00000406="dk"
00000407="gr"
00000408="gk"
00000409="us"
0000040A="sp"
0000040B="su"
0000040C="fr"
0000040E="hu"
0000040F="is"
00000410="it"
00000411="jp"
00000412="ko"
00000413="nl"
00000414="no"
00000415="pl"
00000416="br"
00000418="ro"
00000419="ru"
0000041A="yu"
0000041B="sl"
0000041C="us"
0000041D="sv"
0000041F="tr"
00000422="us"
00000423="us"
00000424="yu"
00000425="et"
00000426="us"
00000427="us"
00000804="ch"
00000807="sg"
00000809="uk"
0000080A="la"
0000080C="be"
00000813="be"
00000816="po"
00000C0C="cf"
00000C1A="us"
00001009="us"
0000100C="sf"
00001809="us"
00010402="us"
00010405="cz"
00010407="gr"
00010408="gk"
00010409="dv"
0001040A="sp"
0001040E="hu"
00010410="it"
00010415="pl"
00010419="ru"
0001041B="sl"
0001041F="tr"
00010426="us"
00010C0C="cf"
00010C1A="us"
00020408="gk"
00020409="us"
00030409="usl"
00040409="usr"
00050408="gk"

For more informations about keyboard layout check Microsoft Support Site:

The input locale does not type the chosen keyboard mapping in the MS-DOS window

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.