Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Wowza Media Server for video streaming to mobile devices and have troubles with RTSP-streaming to Android 2.1. I tried their test .mov file and it works. But when I try to play my own .mp4 files, I get only the audio, but no picture.

Here are the ffmpeg settings I used to encode files:

-r 12 -s 176x144 -f mp4 -acodec libfaac -ab 24k -ar 48000 -vcodec libx264 -level 30 -b 56k
-flags +loop+mv4 -cmp 256 -partitions +parti4x4+parti8x8+partp4x4+partp8x8+partb8x8
-me_method hex -subq 7 -trellis 1 -refs 1 -bf 0 -flags2 +mixed_refs-wpred-dct8x8 -coder 0
-wpredp 0 -me_range 16 -g 250 -keyint_min 25 -sc_threshold 40 -i_qfactor 0.71
-qmin 10 -qmax 51 -qdiff 4 -maxrate 10M -bufsize 10M -threads 0

After encoding I did qt-faststart video.mp4 and MP4Box -hint video.mp4 Could you please tell me what am I missing or doing wrong?

share|improve this question
up vote 0 down vote accepted

I've solved my problem by using EncodeHD. It knows how to prepare video for different kinds of devices, and in the logs I have found the necessary command-line to use with ffmpeg:

-vcodec libx264 -coder 0 -flags +loop -cmp +chroma -partitions +parti4x4+partp8x8+partb8x8 -rc_eq 'blurCplx^(1-qComp)' -me_method hex -subq 6 -me_range 16 -g 250 -keyint_min 25 -sc_threshold 40 -i_qfactor 0.71 -b_strategy 1 -qcomp 0.6 -qmin 10 -qmax 51 -qdiff 4 -directpred 1 -flags2 +fastpskip -threads 0  -level 30 -b 1012k -minrate 1012k -maxrate 1012k -bufsize 1012k -s 480x270 -r 30 -acodec aac -strict experimental -ac 2 -ar 44100 -ab 96k

Sorry for answering my own question. I hope that helps someone.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .