Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I open firefox , it tries to open
The above website isn't my home page , Google is my home page.

How can I fox it ?

share|improve this question
+1 for the (I'm assuming) pun. I hope you end up foxing it too. – n0pe Jun 30 '11 at 18:05
up vote 2 down vote accepted

I just went to that page.. I think you're being sent there as a means of reporting "FATAL ERROR : The dynamic C library contained in the extension file could not be found."

The page you linked provides a series of solutions, depending on your particular situation. For example, the first such solution is to reinstall the dynamic C library.

I suggest you go read that page in detail and follow the instructions there. I suspect once you've done that, starting up Firefox will take you to your home page normally.

EDIT: Here are the instructions from that page, as per request:

Cause 0 : since 16-NOV-2007, there is a bug in for MacOsX ! proposes a update for the extension for MacOSX since the 16-NOV-2007 while there is no such update on the site. A bug was logged in bugzilla. Please vote for it if you want it to be solved !


Cause 1: Operating system mismatch

This can happen when you have installed a version that is not for your Operating system (OS). For example, installing the Linux version on Windows or the opposite. The extension is available on Windows, MacOsX, Linux 32bits, Linux 64bits and Linux PPC. This happens mostly due to bad autodetection of the OS or caching issue in

Solution: re-install the extension for your OS.

  1. Please, look at the list of OS here, and install the version for your OS. Take care to allow this site to install an extension (green toolbar at the top)

  2. Retry in and take care that the version installed is the one for your OS.

Cause 2: Linux

A. On linux, depending of your linux distribution, it can be that the standard C++ libraries installed on your distribution are not the one linked with the extension. To correct this, please read the detailed info, here:

Take also care that the extension is different for Linux 32bits (most common), Linux 64bits and Linux PPC.

B. In an update on Debian from about June/July 2006, solved in about August 2006. The extension does not work on Debian anymore. The reason is the way debian has changed his way to link the XPCOM library in Firefox.

Cause 3: Windows Vista

You need to be administrator to install the extension on Firefox in Windows Vista.

Cause 4: Seamonkey upgrade

When reinstalling a new version of Seamonkey on an existing one, Seamonkey warns that it will deregister all components. Practically, the library of the extension is deinstalled. To solve this, just reinstall the extension. Download here

Cause 5: Browser (Netscape 7.x, 8,x, Seamonkey 1.0.x)

Like told in the download area, the extension has been tested on Firefox, Mozilla Suite 1.7. It is reported to work on Flock without any issue.

It does not work on Seamonkey, nor on Netscape 7.x or 8.x. If you use these browser please deinstall the extension. See uninstall instructions below.

Case 6: Other

Check the forums

If you do not find an answer, add your question in it . Then contact me if you do not find a solution : Marc Gueury :

To uninstall the extension:

In Firefox, Flock, - go in the Tools/Add-ons menu (called Extensions in previous versions) - choose HTML validator in the Extension list - click uninstall - restart Firefox.

For other browsers, see - -

Additional info:


In the Java console, you will see this error message

Error: Components.classes[';1'] has no properties
Source File: chrome://tidy/content/tidyUtil.js
Line: 96
share|improve this answer
Could you please edit your post with the Instruction there, I cannot open the page !!! – Mohammad Dayyan Jun 30 '11 at 17:38
Yup, took a few minutes, so there ya go. Hope that helps you? – Doc Jun 30 '11 at 17:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .