Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using ThinkPad x120e with Ubuntu 11.04. I updated the graphics driver using "Additional Drivers" program (AMD Radeon™ HD 6300M Series Graphics.) When I work at home, I want to use my external monitor. So, I changed some settings using ATI Catalyst Control Center, disabled notebook's display, set external monitor as default and restarted.

Now, login screen is only shown in external monitor just like I wanted, however when I log in to my account the display switches from external monitor to notebook's monitor, and external monitor is disabled. When I go back to login screen, display switches again. I want to use external monitor only as long as it is connected to the computer. Any ideas how I can do that, and why the computer is behaving like that?

share|improve this question
    
Can you use the "monitors" application in Ubuntu to configure your display? I have an X120E also running 11.04, heh, cool. Though I've avoided switching back and forth monitors like that on Linux, just seems like it'd be a source of misery. But I believe there's been a lot of work in the last few years, I think xrandr was created to really aid with this sort of thing... –  Doc Jun 30 '11 at 19:08
    
Yes, I can see monitors application, but it doesn't give me any options I can use. That's why I'm using Ati Catalyst. –  blahbaa Jun 30 '11 at 20:19
    
I see. I suggest you then try removing the Catalyst driver, completely.. Then try running on the open source ATI driver ("radeon"). You may be able to use that driver for this. Though I wouldn't be especially optimistic. There are ways of doing this somewhat decently if you can stand to restart your X session every time you want to switch display configurations. –  Doc Jun 30 '11 at 20:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.