Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Occasionally I encounter a strange bug in Microsoft Word 2010. Consider the following document part:

enter image description here

This box contains six paragraphs:

  1. Header "Lemma"
  2. Line with word "Let"
  3. Equation
  4. Line with text "be the gravitational field. Then"
  5. Equation
  6. Line with text "for any closed surface S enclosing the origin."

However, for some reason, the fourth line is rendered twice. If I edit the fourth line, the 'ghost line' is updated simultaneously. And, as you can see, if I select a part of the fourth line, the selection is also drawn on the 'ghost line'.

Is there any way of removing the ghost line?

share|improve this question
    
Mmmm astrophysics.. Yummy. This sort of sounds like the kind of bug you can get around just by screwing around with formatting, a lot.. –  Doc Jun 30 '11 at 20:13
5  
Does this show up when you print preview the document? Also, you might like LaTeX for this sort of thing in the future ;) –  Breakthrough Jul 4 '11 at 19:14
    
Happens in Word 2011 very often. –  Vervious Jul 4 '11 at 19:19
1  
Not a fix for the bug, but I'm confident that you would accept "LaTeX" as a solution and never look back if you were to give it a try :-) –  Kerrek SB Jul 4 '11 at 19:32
    
@Breakthrough, @Kerrek: Well, to be honest, I have never in my life been as upset on a computer program as I was with Word 2007 and is with Word 2010. This problem is what I would classify as a 'minor Word annoyance'. What really makes me upset is the auto-destru‌​ct feature of Word 2007 (and 2010) documents. –  Andreas Rejbrand Jul 4 '11 at 19:36
show 8 more comments

2 Answers 2

I fixed this by deleting the endline before the first instance. This caused my the previous line and the first instance to append, and the second instance to disappear completely.

share|improve this answer
add comment

The issue is resoved (in my case) by removing the 'Keep lines together' option in the paragraph settings.

The Paragraph Settings Dialog

But, clearly, this is a bug (one of many in Word 2007 and 2010...). Now, it isn't terribly important for me to have this paragraph setting on in this style, so I can live without it in this case.

If you want to experiment yourself with this issue, have a look at

The following additional details seem to work for Word 2007.

The 'Keep lines together' option must be unchecked for all lines containing equations. Other lines with text may have the 'Keep lines together' option checked without causing paragraph duplication.

Another indicator of the problem is misplaced equation highlighting as the mouse is moved around and near the lines containing equations.

share|improve this answer
    
It would be interesting to get a confirmation that the problem isn't only seen on my system. Anyone? –  Andreas Rejbrand Jul 9 '11 at 23:47
    
Something Einstein said about insanity comes to mind. If you want different results, you have to stop doing the same thing. –  David Schwartz Sep 23 '11 at 13:23
    
@Gareth: Thank you for observing that the image link was missing. I always upload my images to my private site privat.rejbrand.se, and I guarantee that I will never remove a file from that site, once uploaded there. However, as you noticed, my web hosting provider experienced technical difficulties the other day, so my entire collection of web sites (such as the main site rejbrand.se) went offline for a day or two. –  Andreas Rejbrand Oct 19 '11 at 17:59
    
Thanks @Andreas - note that I am doing a site-wide reupload of images and wasn't targeting your images in particular. See here: meta.superuser.com/questions/3558/… –  8088 Oct 20 '11 at 2:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.