Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My small laptop has a small keyboard, which lacks a Pause/Break key. Ctrl-Alt-Break toggles Full Screen mode in Windows Remote Desktop. Without a Break key, how can I enter Full Screen mode?

I know I can exit fullscreen mode with the mouse.

Maximizing the window doesn't help.

This matters more on small laptops because the screens are small (so you need all the real estate you can get) and because the keyboard lacks dedicated PgUp/PgDn and other dedicated keys (so I can't easily use the RDP alternatives like Alt-PgUp).

share|improve this question
1  
Are you sure you don't have break as a Fn? –  viking Jun 30 '11 at 22:01
    
That's weird; maximizing the window makes RDP go full-screen for me, everywhere I use it. What happens when you maximize yours? Also, there's almost certainly a way to send Break; what make and model of netbook is it? –  boot13 Jun 30 '11 at 22:15
    
If the resolution of the local screen is smaller than the resolution of the remote PC, then maximizing will not make it go full screen, as you'd lose the scroll bars. –  Pangea Jul 6 '11 at 2:54
    
@boot13 - RDP always used to go full screen but since v6.0 it maximises when the screen resolution and mstsc resolution both match, instead of going full screen. It's so bleeping irritating, as my boss's new laptop doesn't have a break key, meaning I have to watch him clunk around scrolling up and down every time he needs to get to the start bar. –  Mark Henderson Nov 21 '11 at 0:01
    
I even tried the Windows On-Screen Keyboard and had no luck. OP's own answer is my favorite. –  sidewaysmilk Apr 28 '12 at 8:52

9 Answers 9

up vote 15 down vote accepted

This is a known issue with systems running Windows 7 / Server 2008 R2 whose resolution is set at 1366×768. Microsoft has created a hotfix which you can read about / request here: http://support.microsoft.com/kb/2582172

If you're lazy or don't want to give MS your email, you can just download it from here. Just know that by doing so Microsoft will have no way of notifying you if there is a recall on the fix.

share|improve this answer

Ideally you could find a configuration option for mstsc.exe that lets you change that setting.. Or possibly a reg edit.

If you have some key you don't really use, you could remap it to function as a break key. You can use any of a large number of windows programs to remap keyboard keys. This article discusses 3 such applications.

share|improve this answer
    
Except that break is a special key and can't be mapped onto another key. (Owner of a brand new samsung laptop that has a numeric keypad, but no pause/break key.) –  sean e Dec 15 '11 at 21:06

If you're in full screen mode and you minimize, and then restore, it comes back in full-screen mode. So I've learned to always minimize, and not de-maximize from the panel that slides down at the top of the RDP screen.

I also made it easy to reconnect if I lose my full-screen state. First, I RDP to each machine and save credentials. (Only do this if you're on a secure machine). Second, I create a small batch file that looks like this:

start mstsc /v:%~n0 /f

I name the batch file after the computer I want to connect to. I put this in an easy-to-reach location (I have a dedicated toolbar on my task bar). Now, when I loose my fullscreen state, I just rerun this batch file and a few seconds later I'm back in full screen.

share|improve this answer
    
Your advice to just minimize will help me in the future. Your batch file one liner saved my bacon just now. Simplified, that looks like start mstsc /v:10.1.1.10 /v if your target computer is 10.1.1.10. THANK YOU! –  sidewaysmilk Apr 28 '12 at 8:43

I used AutoHotKey as recommended in this question to map CapsLock to break using this binding: CapsLock::CtrlBreak

AutoHotKey needs to be running for the binding to hold. It is not a simple registry change that can be done with most other keys.

share|improve this answer

Other have addressed the symptom, but to address the underlying question/issue, are you absolutely certain that your laptop does not have a Break key? Even netbooks usually have one; if it doesn’t get its own key, it usually shares one with Insert.

Perhaps it is simply not printed on the key (particularly common with after-market/replacement/generic keyboards).

You did not mention the make/model of the laptop, but check the manual/docs to see if you have to do anything special to signal that key such as pressing Ctrl+Fn+F11.

Unless the manufacturer is really trying to cut costs, it is usually included because as sean mentioned, Break is a special key. It is similar to how Ctrl+Alt+Delete is/was specially handled by the keyboard controller at a hardware level (a direct line to the reset pin on the CPU).

share|improve this answer
1  
Or it could be like mine, where my right Shift key is also labelled Pause and functions as a Break key when pressed with Fn held. Yes, that's convoluted. –  Bob Jun 4 '12 at 0:42
    
Yup; most of the keys are usually there and just require some weird two- (or more) key chord. Most of the time when they want to cut costs, they instead just cut the extra (usually the right) modifier (Ctrl, Alt, Shift, Win) keys. –  Synetech Jun 4 '12 at 0:48

Press Ctrl + Fn + Alt + Insert

This works for few laptops where you do not find Break key. It works on a Dell Latitude 6420.

share|improve this answer
    
Works on my Dell Latitude also! –  Stabledog Oct 11 '13 at 5:26

I have a Lenovo E430 and was struggling with this very issue. None of the answers here worked for me because Fn+Insert does not equal Break on this keyboard. Fn+B is the shortcut.

As such, pressing Ctrl + Alt + Fn + B maximizes the RDC window.

Source

share|improve this answer
    
In my experience, pressing Ctrl+Alt+Fn+B altogether often failed. Here is how I do it: hold Ctrl+Alt first, then press Fn+B. –  suud Mar 10 at 9:11

Check that F Lock isn't/is turned on. My break key doesn't work unless F Lock is turned off.

(P.S. I hope the person who invented F Lock got their just desserts)

share|improve this answer

In HP laptops you have to press Ctrl+Alt+Fn+PageDown. This is equivalent to Ctrl+Alt+Break.

Its working with HP Probook series. I am using HP Probook 4440s

Remote Desktop Services Shortcut Keys

share|improve this answer

protected by Oliver Salzburg Oct 12 '12 at 13:55

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.