Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Trackpad usually works, but sometimes stops responding for around 5 seconds and then suddenly starts working again. Seems to happen when I switch between typing and moving + button-clicking and also when I do a lot of double-clicking. Tried turning off the "Ignore accidental trackpad input". Apple replaced the keyboard/mouse under warranty. Problem remains. Any ideas?

White non-unibody Late-2008 13" MacBook - fully up-to-date OS. Doesn't seem to matter if it is plugged in or not. Updated to Snow Leopard - seems to have made it worse.

share|improve this question
When they replaced it, did they actually say something was broken? – Arjan Sep 22 '09 at 19:30
And anything plugged in to the USB ports? The trackpad is said to be connected to one of those, according to "The MacBook. All USB Ports Are Not Equal" at – Arjan Sep 22 '09 at 19:32
@Arjan, they didn't say either way. I think they just blindly replaced it. Nothing plugged in to the other USB ports. Thx. – Hafthor Sep 22 '09 at 20:46
Given this was a bounty question has has been accepted it might be worth creating a new question with the new problem. Reference this one and explain why it's not a duplicate. – ChrisF Feb 5 '10 at 9:25
Does the problem occur no matter what application you use? How did you install Snow Leopard? I assume you just upgraded (which, I guess, could leave troublesome software in place) or did you happen to use "Erase and Install" (as described at (As an aside: from what I've heard, re-installing 10.6 is always a "Archive and Install" now.) – Arjan Feb 5 '10 at 10:28

If you have a unibody Macbook, Apple released a firmware upgrade for the trackpad a while ago that is supposed to fix this issue. It is available via Software Update.

If you aren't using a unibody Macbook, you can try putting the palm of your hand over the trackpad for 5 seconds to restart it.

share|improve this answer
@John T: Do you have a link to an Apple doc describing that trackpad reset procedure? I've heard of it before, but never run across any official docs on it. – arathorn Aug 27 '09 at 4:33
It's been around since the good old powerbooks. Can't find much documentation but it's suggested here in step 3: – John T Aug 27 '09 at 4:39
@John T: Nice, thanks. – arathorn Aug 27 '09 at 4:52
@John T: Tried that reset procedure, no help. But thx for trying. – Hafthor Aug 27 '09 at 7:03

You may be running into the "Ignore Accidental Input" feature of the trackpad. It is an option in the Trackpad preferences. It tends to ignore all but the center of the trackpad shortly after you start typing.

Here is an apple article on it (screen shot is out of date, I believe):

share|improve this answer
Thx. As mentioned in the question, I've tried disabling this to no effect. – Hafthor Sep 23 '09 at 0:29

Not much chance of this being your problem, but there have been some reports of the battery swelling and exerting pressure on the trackpad from below and causing problems. If you have a swollen or deformed battery, get a replacement.

share|improve this answer
Also check this article :… – harrymc Sep 26 '09 at 15:51

Maybe try Resetting the System Management Controller.

The System Management Controller is an integrated circuit (computer chip) that is on the logic board of the computer. As the name implies, it is responsible for power management of the computer. It controls backlighting, hard disk spin down, sleep and wake, some charging aspects, trackpad control, and some input/output as it relates to the computer sleeping.

share|improve this answer
thx, but no effect. – Hafthor Sep 20 '09 at 9:19
Yeah I tried it once and it made the problem worse >.< (the problem I had was machine wouldn't charge or get power from the magsafe. turned out to be a loose connection). – Nippysaurus Sep 21 '09 at 2:32
@Nippysaurus, you tried it once and it made the problem worse, and then you advised someone to try the same...? ;-) – Arjan Sep 23 '09 at 8:29
@Arjan van Bentem, yep. In my case nothing could help, the hardware had taken some damage and needed repairs. There is no way that doing this will damage an undamaged machine. – Nippysaurus Sep 24 '09 at 12:47
up vote 0 down vote accepted

Applying even a little pressure to the left palm rest creates this condition. Apple replaced the top case again and this time it seems to have corrected the problem, although, it looks like they may have added a spacer on the left palm rest to "fix" it.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .