Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

About once or twice a week my laptop will wake up in the early hours of the morning (about 6ish) from sleep mode. This happens whether the AC power is connected or not. It will then turn itself off after a few minutes. The only way I can stop this happening is to shutdown the computer every night, but I would like to leave it in sleep mode if I can I don't have to wait ages for it to boot up in the morning.

I can't remember what days of the week it does this or if it's random, I've been shutting down windows every night for a while now. I have automatic defragment turned off and my virus scanner is only set to run at midday.

I know it's a windows 7 issue because it doesn't happen when I'm running linux. How do I find what's causing my laptop to wake and stop it from happening?

share|improve this question
    
Sorry I've been extremely busy lately and haven't had much time to go over these things. I promise I will accept/vote-up answers and comments as soon as I can. –  Eddy Jul 6 '11 at 11:10

4 Answers 4

up vote 13 down vote accepted

Windows Update or Back-up and Restore shouldn't be doing this, search the root cause in your event log and also try the powercfg -lastwake command which will list what the last wake was.

enter image description here

Disable that option, see what powercfg -devicequery wake_armed lists and disable their wake.

enter image description here

share|improve this answer
    
Thanks, I already had "Allow wake timers" disabled and now I've disabled waking from touchpad and keyboard. I'll try it out for a week and see if it wakes again. If it does I'll have a look at the "powercfg -lastwake" command to see if that helps. Sorry it's taken me so long I'll accept your answer soon if this all works –  Eddy Aug 3 '11 at 10:33

Go to Control Panel>System and Security>Administrative Tools>Task Scheduler

Look at the "Status of tasks that have started in the following time period" to determine what task is waking the computer.

Then find the task in the pane below, click "Properties" in the right pane (you can't just double-click the task), and click the "Conditions" tab, and uncheck "Wake the computer to run this task".

enter image description here

You can also highlight the task, and click "End" in the right pane to end them all.

share|improve this answer
    
Using "powercfg – lastwake" as the other said will probably get you to the exact task more quickly then looking at the log of tasks that recently ran. Then you can set it not to wake the computer as in the screenshot. –  KCotreau Jul 1 '11 at 12:06

Your network card may be waking up your computer. Try disabling the "allow this device to wake the computer" option for it.

  1. Right click on your “My Computer” then select Properties.
  2. Click Device Manager on the left side of the Properties window.
  3. Check your Network card on the Network Adapters (Click on the + sign to expand).
  4. Right click on your network card and select properties.
  5. Go to the Power Management tab and untick the option there to prevent your network card from ever waking up your Windows.

Also, to see exactly what caused your computer to wake up last, go to a command prompt and type in the following:

powercfg – lastwake

That will give you detailed info on what woke up your computer. You can also try this command:

powercfg –devicequery wake_armed

Above Source: http://www.cravingtech.com/fix-windows-vista7-sleep-mode-from-waking-up-by-itself.html

If all that fails, maybe you have a Scheduled Task set to run and wake up your computer? Check Control Panel -> Scheduled Tasks and see if any are set to wake your computer up.

share|improve this answer

It might be that you have windows update set to weekly updates, or that it's configured to weekly backups.

So check "Control Panel -> System and Security -> Backup and Restore" and "Control Panel -> System and Security -> Windows Update".

Another tip is to check "Control Panel -> System and Security -> Administrative Tools -> Task Scheduler" to see if there is something strange there.

last tip is to check after a forced wake up "Control Panel -> System and Security -> Administrative Tools -> Event Viewer" to see if anything registred at well 6'am.

share|improve this answer
    
I had windows update set to 03:00 every morning! I'm not sure if this was causing it to wake 'cause I thought it was waking later than that, but I've changed that now –  Eddy Aug 3 '11 at 10:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.