Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After reading this thread I might have figured out why the CHKDSK-prompt starts.

But the biggest problem is that when it prompts me with Press any key with in 10..0 seconds, nothing happens until the timer hits 6, then CHKDSK starts the check even though I've pressed any button (and yet it's 4 seconds left).

This question states the problem as it appears at me, though the answer is wrong.

Why does the actual check start after 6 seconds, and is there any way to disable it from within Windows?

share|improve this question
    
Do you want do disable the checking altogether, or just the timer? What is "it"? –  KCotreau Jul 1 '11 at 16:31
    
The checking altogether. –  whirlwin Jul 1 '11 at 16:33
add comment

3 Answers

up vote 2 down vote accepted

Do this command:

bcdedit /set {current} bootstatuspolicy ignoreallfailures

Similar is

bcdedit /set {default} bootstatuspolicy ignoreallfailures

They can be the same if you are booted into the default load, so default would equal current.

For more information, the relevant Google search is "disable Windows Error Recovery" (minus the quotes).

http://msdn.microsoft.com/en-us/library/ff794974(v=winembedded.1001).aspx

share|improve this answer
add comment

If you want to disable it you may need to clean the folowing registry key: "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\BootExecute" You will find "autocheck autochk *" on this key. Just clean it and it will be disabled.

share|improve this answer
add comment

One possibility, but after seeing the date of the article I assume this has already been patched on a fully patched system, not sure, you could see what the version of your autochk.exe is currently installed, see if it matches the patch version listed on the page.

Note: W7 64bit may have both 64 and x86 versions of the autochk file, one in System32 and one in SysWOW64 folders, check both.

On a computer that is running Windows 7, you use the Chkdsk.exe program to schedule a disk check during the next system startup. However, the disk check does not start correctly. Specifically, you may experience one of the following issues the next time that you start the computer:

A countdown timer is displayed and you are prompted to press any key if you want to skip the disk check. However, after you press a key, the countdown timer continues. Eventually, the system may stop responding at the count of 1, or start without performing the disk check.

The countdown timer is not displayed and the disk check starts immediately.

The countdown timer is displayed. However, the disk check starts before the countdown timer reaches zero.

This problem is more likely to occur on computers that have infrared devices equipped.

Source of Information

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.