Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a laptop with a set of external speakers hooked up to it on my computer desk. The speakers use the standard 3.5mm audio (headphones) jack. The speakers work fine, but I've recently added a separate monitor to my laptop via HDMI. With the monitor hooked up to my laptop and the speakers still hooked up to the laptop, sound will only come out of the built-in monitor speakers.

When I look at my audio settings, there are three different "audio playback devices" showing up, but only the built-in monitor speakers make noise when I click "test" (and I hear nothing when I set any of the other devices as the default.

Does anyone know how I can still use my external speakers when using a separate monitor with my laptop? I'm hoping there is a solution that doesn't require the laptop to be open or closed, because I use both scenarios.

I came across this post, but it doesn't look like they had much luck.

share|improve this question
    
Does you monitor have a headphone jack? –  William Jackson Jul 1 '11 at 17:01
    
There is an audio input, but no output. I tried hooking my speakers up through the input, just to try it, but the sound still came out of the monitor's built-in speakers. –  lhan16 Jul 1 '11 at 17:03
    
@Lloyd do you receive the same issue when using VGA/DVI? Or is this not an option. –  sealz Jul 1 '11 at 17:14
    
I haven't tried yet. My laptop doesn't have DVI, but there is VGA so I'll give that a try when I get home from work. It may be that HDMI carries audio? –  lhan16 Jul 1 '11 at 17:17
    
@Lloyd, that would be my guess, try disabling the ones you dont want as mentioned in my answer. HDMI is the obvious choice for looks..if only you had DVI. –  sealz Jul 1 '11 at 17:19

3 Answers 3

up vote 3 down vote accepted

I believe this has something to do with your HDMI setup since HDMI also produces sound. If you right click on the sound icon in the windows task bar and choose playback devices. This should list everything that is producing sound.

Right click on the ones you want to avoid and choose disable. And then configure your speakers as the default

share|improve this answer

Right click on the speaker emblem in the right bottom corner of the computer (taskbar). Click on playback devices, then if your hdmi cord is plugged in, the option should be there for HDMI output. Click on this and choose make default, then okay, for the period of time you are using it with the HDMI cord, and when you are done, put it back to regular speaker and choose set default again, and then apply.

share|improve this answer

hey to fix this problem go back into your audio setting and right click on the sound device you would like to use and set it to default and it should work. if for some odd reason it seemed to fail then see if your monitor has a 3.5mm audio plug on it and use that. if the monitor does not have this feature then trade it in for a similar monitor that does not support audio.

share|improve this answer
    
I've already tried changing that audio setting - refer to the original question. And trading my monitor in is not an option. Thanks. –  lhan16 Jul 1 '11 at 17:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.