Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

ipconfig /release is not working, why is that?

here is a sequence where I put my cable in get an IP, try ipconfig /release and it tells me it can't release wireless, but there is no wireless connection. i'm just trying to release the wired one.

unplug cable

 C:\>ipconfig

Windows IP Configuration


Ethernet adapter Wireless Network Connection:

        Media State . . . . . . . . . . . : Media disconnected

Ethernet adapter Local Area Connection:

        Media State . . . . . . . . . . . : Media disconnected

Fine so I plug my cable in

C:\>ipconfig

Windows IP Configuration


Ethernet adapter Wireless Network Connection:

        Media State . . . . . . . . . . . : Media disconnected

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . :
        IP Address. . . . . . . . . . . . : 0.0.0.0
        Subnet Mask . . . . . . . . . . . : 0.0.0.0
        Default Gateway . . . . . . . . . :

C:\>ipconfig

Windows IP Configuration


Ethernet adapter Wireless Network Connection:

        Media State . . . . . . . . . . . : Media disconnected

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . :
        IP Address. . . . . . . . . . . . : 192.168.1.8
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.1.254

Fine so from above, it clearly has an IP. the above is normal.

C:\>ipconfig /release

Windows IP Configuration

No operation can be performed on Wireless Network Connection while it has its me
dia disconnected.

C:\>

the following doesn't matter much, but I no doubt meant to also say, that after , doing ipconfig /release, ipconfig showed the LAN still has an IP. but I and everybody assumed that from the title- correctly.

so, ipconfig /release didn't work on the LAN.

and for those that don't bother to read the comments, the ultimate answer/reason, was that it was a static ip and that's why ipconfig /release didn't work on the LAN.

share|improve this question
    
@datatoo yes I do have a cable connected, of course, re-read the question, and ipconfig /release should work –  barlop Jul 1 '11 at 19:07
    
@datatoo no you've totally misread, I have no wireless 0.0.0.0 you may as well remove your comment it's a complete shambles. –  barlop Jul 1 '11 at 22:14
1  
you are absolutely right, misread it totally –  datatoo Jul 1 '11 at 23:31
    
@KCotreau I notice your answer has been deleted, or you deleted it. Do you still contend that it released, despite my screenshots which were in comments with your answer, proving that it didn't. Did you delete it because you decided you were wrong? –  barlop Jul 4 '11 at 10:32

2 Answers 2

up vote 6 down vote accepted

Normally without a specific adapter being listed, ipconfig is supposed to work on all the adapters. Obviously yours is not in this case. Try focusing ipconfig on the local area connection adapter instead:

ipconfig /release local*
share|improve this answer
1  
that's better now I get the specific message, "Adapter Local Area Connection is not enabled for Dhcp." and changing it to DHCP now I can do /release. So, solved. nice one. –  barlop Jul 1 '11 at 19:10
1  
ipconfig /release all –  Moab Jul 1 '11 at 19:30
    
@Moab an interesting one to know of +1, though that gives a different error in that situation, it says "The operation failed as no adapter is in the state permissible for this operation.", an error msg that is not so specific. but good to know about anyway. –  barlop Jul 1 '11 at 22:07
    
ipconfig /release * <-- that covers lan* gives the same (useful) specific error message. –  barlop Jul 1 '11 at 22:07
    
When I get that error message, I reboot, if that does not work, uninstall the network device in Device Manager, reboot. –  Moab Jul 1 '11 at 22:37

It's pretty simple, really. Goto msconfig, and start you services back to default. Restart computer. open Command Prompt as Admin.

--netstat -ano

Put that data in your short term memory bank for a minute

--ipconfig /release    
--Ipconfig /renew      
--ipconfig /flushdns

exit

Goto network properties and recheck the boxes you may have unchecked prior to knowing what you were doing, maybe.

share|improve this answer
    
not sure why you're talking about bringing up msconfig or the rest, and the reason why wired was not being released was that it was static, as you'd know if you read and understood the comments and answer(s) already posted –  barlop Dec 15 '12 at 9:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.