Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two laptops with 802.11n-capable wireless adapters (Intel WiFi Link 5100 AGN and Atheros AR9285) in them. However, I can't find a way to connect them at a speed higher than 54 Mbps. The methods of connection I've already tried are:
1) an ad hoc connection;
2) Windows 7 Wireless Hosted Network (netsh wlan start hostednetwork);
3) Connectify software;
4) Intel My WiFi software.
In all cases I used WPA2 security. The network is recognized as 802.11n, but the speed is always 54 Mbps only. What can be preventing the connection from using higher speeds? Both laptops run Windows 7 Ultimate.

share|improve this question

4 Answers 4

up vote 3 down vote accepted

Finally figured it out. The problem was caused by the Atheros AR9285 adapter - its 802.11n capability was locked, and after using the Atheros EEPROM Tool to unlock it, the connection speed increased to 65 Mbps. The AR9285 can run at 150 Mbps on a 40 Mhz channel though, so if anybody knows how to make a Wireless Hosted Network / software AP use a wide channel, please reply.

share|improve this answer

I think that AdHoc is one of those fuzzy areas not covered in the N spec, and may default to B speeds. See if the devices have an extra option for AdHoc in the device settings, some do I have heard.

share|improve this answer
    
The Atheros adapter indeed has an "ad hoc 11n" setting, which is enabled. However, the connection variants 2-4 use Infrastructure mode with one of the laptops acting as a software access point, and shouldn't be affected by ad hoc limitations. Still I can only reach G speeds. –  SlimShaggy Jul 1 '11 at 20:53
    
If they were the same adapter and had the setting enabled on both you might have some success. –  dbasnett Jul 1 '11 at 21:23
    
Well, I can use Infrastructure mode instead of Ad Hoc mode, so the setting becomes irrelevant. Why do I still get 54 Mbps? –  SlimShaggy Jul 1 '11 at 21:31
    
I think the answer is an inexpensive N-AP, or wait for the next release of the drivers for the wireless cards and hope that AdHoc has been fixed. –  dbasnett Jul 2 '11 at 16:15
    
OK, I'll try to make it clear once again: I have 54 Mbps even when I'm NOT using AdHoc. –  SlimShaggy Jul 2 '11 at 17:41

You could always try Connectify. I don't know for a fact that it will solve your problem though.

share|improve this answer
    
I've already tried Connectify, it is mentioned in my question. –  SlimShaggy Jul 2 '11 at 5:37

You might try reading this article:
http://erratasec.blogspot.com/2009/11/windows-7-includes-soft-ap.html

It tells you how to set up a virtual access point on Windows 7 (a "Microsoft Virtual WiFi Miniport Adapter"), so that the two machines will be able to connect using infrastructure mode rather than ad hoc. The short version is enter a command like the following into an elevated command prompt:

netsh wlan set hostednetwork mode=allow ssid=Test key=letmein9

The will give you a new network named "Test" with a password of "letmein9"

share|improve this answer
    
I've already tried this, it is listed in my question as the connection method #2. In addition, I've already overcome the 54 Mbps barrier, and am now stuck at 65 Mbps, as stated in my post marked as the accepted answer: superuser.com/questions/305188/…. –  SlimShaggy Jul 9 '11 at 8:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.