Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a 120 GB Seagate SATA hard drive formatted as the default "Mac OS Extended Journaled" in a 2006 MacBook with Snow Leopard. It also has Windows XP installed with BootCamp. Everything worked fine until I was forced to hard-boot the Mac when the operation system froze. Now when I boot the computer, I get a flashing question mark over a gray folder (This means that no bootable OS was found).

What I have tried:

  • Boot from Snow Leopard update CD and use Disk Utility's repair tool.
  • Boot from Tiger OSX install CD and use Disk Utility's repair tool.
  • Boot the mac into FireWire Target Disk Mode to access the hard drive from another mac over FireWire.
  • Connect the hard drive to another computer as an external hard drive with USB.
  • Put the hard drive in a freezer overnight and then retry the above.

For all of the above, the result was the same. The hard drive would never show up on the desktop, in Finder, or in DiskUtility on the appropriate computer. Therefore, any disk repair/recovery utility I try can't find the hard drive to repair it.

I need to recover some files from the hard drive.
Any hints, suggestions, and/or answers would be greatly appreciated. I can post additional information if it would be helpful.

More information:

  • I ran the Apple Hardware Test on the MacBook with no errors.
  • When the hard drive powers on, I hear the read head move and the disc spin for about 25 seconds then both stop.
  • When using FireWire Target Disk Mode with the hard drive in place, it takes over a minute of booting until the FireWire symbol shows on the screen. While, with no internal hard drive installed, it only takes a moment.
share|improve this question
Does the hard drive show up on the SATA bus in System Profiler? If not, then you have a hardware problem and no software tool will help. –  Spiff Jul 2 '11 at 15:19
Wait if you can use the Disk Utility's repair tool on the hard drive, how does it not show up? (I'm understanding that the hard drive has to be there in order to repair it...) –  Vervious Jul 2 '11 at 21:12
Have you tried Disk Drill? It might help you. –  user88840 Jul 4 '11 at 20:13
It doesn't show up in Disk Utility. And I can't use the repair tool. –  cduck Jul 5 '11 at 20:35

2 Answers 2

This sounds very similar to an issue I had only 10 days ago. I tried everything (except the freeze one, that isn't appropriate here, IMHO). Your HD doesn't sound damaged, the structure of the data on it sounds damaged.

You NEED DiskWarrior. When you buy it it comes with a boot disk that will work with your system. You simply boot up your machine with the boot disk DVD in the drive and hold the c key whilst booting. This will boot you into DiskWarrior and from there, you can rebuild your drive's directory. Once it is complete (it may take as much as 24 hours in some cases), you'll reboot your machine and it will probably boot as normal.

share|improve this answer

maybe you can try Kvisoft File Recovery Mac to repair your hard drive. It can help you recover deleted files from hard disk.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.