Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two virtual machines open at the same time in VMWare Fusion. I often switch between OSX and the virtual machines. Switching from OSX to the last virtual machine I used is not too difficult. However switching from one virtual machine to the other is not as simple. I run the virtual machines maximized. In order to switch to the other virtual machine I have to use the menu and select it. If I'm using an OSX application then the menu isn't even showing. Is there some easy way to switch between the different virtual machines?

share|improve this question
    
What are you doing? Might a shell command to the other VM work - or a remote desktop? –  Mark Jul 2 '11 at 12:01
    
I just have multiple VMs open, just like having multiple windows open. The problem is I can't find a keyboard shortcut to switch between the VMs just like there are keyboard shortcuts to switch between windows. –  tony_sid Jul 2 '11 at 12:25
1  
You could report a bug to VMware, that the option Enable Mac OS X Keyboard Shortcuts doesn't work with the window switching shortcut (e.g. Cmd-Backtick) –  Daniel Beck Jul 2 '11 at 14:34
    
I think that's what I was looking for. If I'm in a VM and I press that then it will switch to the other VM. –  tony_sid Jul 3 '11 at 17:30
    
@OSXJedi So the Cmd-Backtick works for you in the virtual machines? –  Daniel Beck Jul 4 '11 at 11:53
show 1 more comment

1 Answer

up vote 2 down vote accepted

You can assign keyboard shortcuts through System Preferences for the menu items named after your virtual machines.

enter image description here

enter image description here

This also works in full-screen mode, even though the "mini menu" doesn't show these shortcuts.

share|improve this answer
    
That works if I click on Window on the mini menu. If I'm inside a virtual machine and try to use those they don't work. –  tony_sid Jul 3 '11 at 0:26
    
@OSX It worked for me with the assigned key combinations in both virtual machines, even though I forward key combinations with command to the VMs. –  Daniel Beck Jul 3 '11 at 5:48
    
What do you mean by "forward key combinations." –  tony_sid Jul 3 '11 at 7:30
    
@OSX Sorry, confused vmware and remote desktop there. My answer works for me though, pressing the keyboard shortcuts I assigned. What vmware fusion version are you using? Do you have the issue of this not working on all VMs? –  Daniel Beck Jul 3 '11 at 9:47
    
Using 3.1.3. It doesn't matter which VM I'm using. I have to click on the mini menu at the top in order for the key combination to work. –  tony_sid Jul 3 '11 at 10:15
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.