Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just purchased a Netgear MBR624GU 3G Router. I want to use it along with my ZTE MF100 modem (which is in their "compatible" list), but it's not working as expected.

The Router has been upgraded to the latest Firmware version (which apparently improves ZTE modem performance) and the ZTE Modem is unlocked and working fine when plugged into my Mac.

The Problem: Whenever I log into the router, the modem is recognized by the router as a ZTE 100 modem, but it never seems to find an operator. If the modem is plugged into my Mac, the ZTE Suite recognizes it fine and finds a network and connects to the internet. The Netgear Router however fails on the same settings.

As you can see from this screenshot, the modem is recognised, but Operator and Network Mode always remain blank, hence the router never connects to the internet.

No Network Results

Netgear support is no good as they want a lot of personal information when signing up for their support which will be used for marketing purposes too, which I really don't want and find appalling.

Has anyone come across this and fixed such an issue?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted
+50

You probably need to clone the MAC address of your computer onto your router. Go to the router's admin interface, and hopefully there will be an option to do that.

Some ISPs use the MAC address of the first computer you use to connect to authenticate you, and refuse to connect to a computer (including a router) with a different MAC address. This is why it is necessary to change the MAC address of the router.

Edit: Netgear's documentation explains how (though their website doesn't say what models it applies to): http://support.netgear.com/app/answers/detail/a_id/1086/~/no-internet-with-new-router,-computer,-or-adapter%3A-mac-spoofing

This guy presents slightly different instructions.

share|improve this answer
add comment

I had a similar issue with my 3G modem when I tried to share it through a router which supported that option. Unfortunately, my wireless provider considered sharing the connection in that fashion out of bounds, and would not allow a connection to the network. As the device is recognized by the router, but doesn't find your provider, you may have similar issue.

I was forced to pay an additional fee for the right to share the connection. If you are looking to share the connection to devices other than your PC or Mac, consider using a product like Connectify.

Or try this or this on your Mac.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.