Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I bought a new laptop and I want to copy some files from the old desktop's HDD, so I bought a crossover cable to connect the two Ethernet ports directly without any hub.

I assigned the IP 192.168.1.1 to the laptop and 192.168.1.2 to the desktop.

Now when I ping from the desktop to the laptop I get the proper response and when I ping from the laptop to the desktop no success returns request timed out.

What went wrong, and how can I transfer all of my data to the laptop?

share|improve this question
1  
What operating systems are you using on the two laptops? That is a rather crucial piece of information for us to be able to help you... –  nhinkle Jul 3 '11 at 5:45
    
Both use Windows XP with Service Pack 3 –  Pavan Kumar C Jul 3 '11 at 6:44
    
Please edit your question to include this information. –  nhinkle Jul 3 '11 at 7:13
    
Flip the cable around, see if the problem follows the direction. –  Ian Boyd Jul 3 '11 at 12:45
    
please include the IPCONFIG reports from both –  Revolter Jul 5 '11 at 12:04

3 Answers 3

Either open firewall ports, or temporarily turn the software firewalls off. Then do your sharing.

After you are done, make sure you turn the firewalls back on, especially, or at least, on the laptop.

share|improve this answer
1  
+1 Disable the Windows Firewall on both the desktop and the laptop. –  Ganesh R. Jul 3 '11 at 4:31
    
He could probably just disable it on the desktop, share the drive, then browse and connect to it from the laptop without problems, but easier to eliminate all FW problems and disable both. –  KCotreau Jul 3 '11 at 4:34
    
no improvement even i make both firewalls ON or OFF , –  Pavan Kumar C Jul 3 '11 at 4:57
    
may be try with another cable..!!?? –  Pavan Kumar C Jul 3 '11 at 4:58
    
If you have the firewall turned off and you can ping, you don't need another cable. With it off, can you now ping both ways? If so, tell us what you are doing exactly at that point. Also, post your IPCONFIG's that you get from a command line. –  KCotreau Jul 3 '11 at 10:12

I'd suggest NOT using the 192.168.x.x netblock (to rule out ip address conflicts, and confusion if either system is connected via wireless)- especially if you are using it for your usual lan. Ping is also turned off by default on windows - you will need to turn it on.

As for the process of actually connecting the system - the steps here work mostly, with the cravats mentioned. If you intend to use the 192.168.x.x netblocks, you will need to change your netmask from what i used in that answer.

You should be able to use shared folders, or connect directly to that system from windows explorer with //ipaddress in the bar which shows the directory.

share|improve this answer
    
Can you give a proper explanation on why not to use the 192.168 block?, I know it will cause IP conflicts if he has a wlan on that address, but lets assume he does not. –  HTDutchy Jul 3 '11 at 8:08
    
well, that's the reason. It makes it easier to rule that out as a cause of the problem –  Journeyman Geek Jul 3 '11 at 8:38
    
ah ok, I was just wondering if you had any other reason, thanks! –  HTDutchy Jul 3 '11 at 8:43

Make sure that the IP addresses aren't using the same network as any other ports on the machines. For example, if the laptop has a wireless connection to your house wireless router and has an IP address of something like 192.168.1.101, then you want to be sure that the network address used between the laptop and the desktop does not use 192.168.1.nn. Perhaps try using 192.168.2.x for the connection between the two computers. Otherwise, the laptop is probably trying to find a computer on the wireless connection.

The network cable should be fine, and you probably didn't even need a crossover cable as most devices now-a-days can sense and reverse the connections if needed. The fact that the ping in one direction work proves that the network ports and the cable are fine.

Definitely make sure the firewall is off, at least on the ports being used between the two computers.

I suspect the reason the desktop could ping the laptop is that the desktop had no 2nd active network connection, so was able to resolve the IP address correctly to the laptop's MAC address. However, the laptop tried using it's other port to resolve the desktop's IP address and no other machine on the home network could answer with the MAC address of the desktop.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.