Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Shift-right-clicking a file should bring up 'Open With' as one of the options in the context menu. In Windows 7, specifically on ".war" files, it doesn't. Any idea why?

share|improve this question
add comment

3 Answers

up vote 4 down vote accepted

I think this is because 'war' files simply had no file association to begin with. Clicking 'open' allows me to select the associated program.

share|improve this answer
    
This is true of XP also. 'Bout to pull my hair out until I saw this. –  Flotsam N. Jetsam Nov 4 '10 at 13:14
add comment

I agree with you: Windows 7 needs a file association to show "Open with..." by shift-right-clicking (just tested with some files with and without file association on Windows 7 Professional - Final). I don't know if this is a bug or a feature.

Just found a nice tool to configure the context-menu: File Menu Tools. Works perfectly with Windows 7 and you can add entries, e.g. open with notepad or open with an other program. Maybe something for you?

To enable or disable context menu entries of the explorer you can use ShellMenuView, it works also under Windows 7.

share|improve this answer
add comment

I have just had the same problem and after trying the method of the previous poster, I found a work around that solved my problem even if the file association is not there:

  • Right click on the file you are trying to open and choose "properties"
  • Next to the "Opens with" instruction, click on "Change"
  • Choose your default program.....

and this works even if the file type has not been given a file association by Windows.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.