Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On Windows 7, I have VirtualBox running Linux (Ubuntu 8.04), with Samba set up so that the Windows host can access it. But if the virtual machine is shut down & restored, or rebooted, the Windows Network no longer shows it.

I've tried refreshing many times, restarting Samba, disabling/enabling the virtual network adapter, and running the succession of commands ipconfig /release, ipconfig /flushdns, & ipconfig /renew, but none worked. As a last resort I could restart the host itself, but is there a better way?

share|improve this question

migrated from serverfault.com Jul 4 '11 at 2:14

This question came from our site for professional system and network administrators.

    
It does not show in the browser or? Can you access the Samba share directly like \\IP.or.hostname? –  xeon Jan 18 '10 at 20:54
add comment

3 Answers

Windows networking uses NetBios for computer name resolution on file sharing. This is configured through the nbtstat command line program not ipconfig. Try running nbtstat -R to purge and reload the name cache. You should then be able to find the machine again or right click on the Computer icon to re-map the network drive manually.

Also is virtualbox using a Bridged network adapter or NAT? When trying to access VMs over the network it is usually easier to setup a bridged network adapter so long as there is a DHCP server available to assign IP addresses. Most cable modems use NAT and DHCP already so they will give private addresses to all of your virtual machines.

share|improve this answer
add comment

Try using another NIC in VirtualBox. There are some bugs in VirtualBox and broadcast packets. (Changing the card may bring up problems. You need to empty /etc/udev/rules.d/70-persistent-net.rules if the system does not recognize your virtual NIC)

Or just simply enable the WINS proxy in your samba configuration file Howto: http://mydebian.blogdns.org/?p=185

share|improve this answer
add comment

The solution is easy. Dont use a NetBios/Samba share. Instead, run a FTP server on the Linux VM and then use Windows7 to create a mapped drive to the FTP server. Its way easier and the performance is way better.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.