Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Dell XPS L502x and I bought which has 2GB NVIDIA GeForce GT 540M Graphics card

enter image description here

But it runs on Intel Graphics

enter image description here

How to use Nvidia Graphics instead Intel Graphics?

share|improve this question
    
Cool story, bro. –  Ignacio Vazquez-Abrams Jul 4 '11 at 5:34
    
I'm fairly certain you can force it to use the Nvidia card from the Nvidia control panel (look under power savings options). –  Breakthrough Dec 11 '12 at 17:48

2 Answers 2

up vote 4 down vote accepted

Your laptop has Nvidia Optimus Technology (Dell help page):

NVIDIA Optimus technology (not available on 3D panel)

NVIDIA® Optimus™ technology automatically optimizes your battery life while maintaining the graphics performance you expect — completely, seamlessly and transparently — whether you’re watching a movie, surfing the Web or playing a game.

How does it work?

  • This intelligent graphics technology switches between discrete and integrated graphics processors automatically whenever it determines what kind of application is being used. If you are simply surfing the Web, the GPU switches to the integrated version, therefore helping to extend your battery life. It's that easy to experience long battery life and amazing visuals without having to manually change settings.

  • Watch an HD movie, surf the Web or play games knowing you can get the long battery life you need and the performance you expect from NVIDIA Optimus technology.

Basically your system is not using the Nvidia card because it doesn't need to. If you were to start watching a HD movie or playing a game then it would switch to using the Nvidia hardware, the fact of the matter is that you're not doing anything that needs the Nvidia card to kick in so your laptop is saving power by turning off the Nvidia card and using the integrated graphics instead.

share|improve this answer

You might need to configure NVidia Optimus to use dedicated NVidia graphics. Usually optimus will automatically switch when dedicated graphics are needed.

share|improve this answer

protected by random May 28 '12 at 5:02

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.