Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a drive mounted on a Windows 7 64-bit machine from a VirtualBox Ubuntu VM via NFS. Whenever I try creating a folder from Windows, the folder is created with its executable bit set to false, rendering it non-navigable and non-writable unless I switch to Ubuntu and manually reset folder permissions.

This bars me from creating folders or using any version control software from Windows. Is there any way to enable setting x permissions on folders creating via NFS?

EDIT: adding info as suggested by jdebp:

I'm using the MS Services for Unix client to map the NFS drive to G:. The output of the nfsadmin client command on the client (thus forth known as my host Windows 7 machine) is:

Service 'NfsClnt' was not found.

I have the server set up on Ubuntu to treat anonymous mounts as uid=1000 and gid=1000 (my Ubuntu user's uid and gid) and the client is configured to have executable flags set in its umask.

When I create a file on the mounted share (either through Eclipse or from Windows Explorer, for instance), the permissions are correctly set:

-rw-rw-r--  1 klemen klemen    0 2011-07-05 09:46 test.txt

But when I create a directory (either from Eclipse, Windows Explorer or from the command line using mkdir), the directory is created without its executable flags:

drw-rw-r--  2 klemen klemen 4096 2011-07-05 09:42 test

My mount options are as follows:

NFS Mount Options

share|improve this question
Show us in your question the output of nfsadmin client on your client machine, and tell us what tool you are using (The POSIX mkdir command? The Win32 md command? Explorer?) to create the directory. – JdeBP Jul 4 '11 at 17:08
What is the share's file system? – evan.bovie Jul 10 '11 at 2:31
The file system on the share is ext4. – Klemen Slavič Jul 12 '11 at 8:32

You must log in to answer this question.

Browse other questions tagged .