Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Running ntpd -q on a Fedora 14 VM gives the wrong time. I'm in the UK so my time should be UTC+1, but instead it's 6 minutes behind what it should be.

Anyone know why this might be and how to fix it?

share|improve this question
    
There's a useful (and comprehensive) White Paper on timekeeping in VMs: vmware.com/pdf/vmware%5Ftimekeeping.pdf –  Linker3000 Jul 4 '11 at 22:23

2 Answers 2

This previous answer Ubuntu time issues recommends against running ntpd in a virtual machine.

share|improve this answer

The time on the server hosting your VM is off. Fix it and check again. Disable ntpd on your virtual machine, and sync to the virtual hardware clock.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.