Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use apache on my MacBook to test SSL with my rails applications, turned it on today and its not working. I just get "Safari can’t connect to the server." for any https requests and I can't work out why. Its acting like apache isnt running but as far as I can tell it is.

I have something else running on port 80 which is working fine, its just https on port 443 that isnt (aka just apache) I now believe that its not picking up on my config in httpd.conf because I added "this wont work" to the end of httpd.conf expecting to see errors on startup but none appeared.

Has there been an update or some config change which will stop apache from loading my config file?

share|improve this question
    
By any chance are you running Skype? I know on the PC version at least it uses ports 80 and 443 when it cannot route using its standard methods. Check the Skype preferences and disable this feature if it is enabled. –  Ruairi Fullam Jul 4 '11 at 12:49
    
I do use skype, but its not in start up so would only interfere when it was open? –  Arcath Jul 4 '11 at 13:30
    
I'm not sure what the case is with the OS X version, whether it registers a service that runs in the background or not. I think with this particular question however, you might find an answer more quickly in a more appropriate forum. –  Ruairi Fullam Jul 4 '11 at 13:53
    
possibly, but that still wouldn't cause apache to ignore httpd.conf or would cause apache to error saying socket already in use when i started it. –  Arcath Jul 4 '11 at 14:06
    
In that case, I'm not certain off hand, I would suggest asking in a forum more suited to webmaster tasks in this instance however. –  Ruairi Fullam Jul 4 '11 at 15:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.