Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have the latest VirtualBox. I have filters for the iPad. But it does not show up in my virtual Windows vista My Computer screen or virtual iTunes. When I try to right click the little USB icon and select it it says

it failed because the device is busy with a previous request
Result code: E_INVALIDARG (0X80070057)
Component: HostUSBDevice
Interface: IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee: IConsole {515e8e8d-f932-4d8e-9f32-79a52aead882}

Any help is greatly appreciated

Note: running 64bit Windows Vista Virtual on a 64bit Windows Vista (Home Premium)

EDIT: my iPad is in recovery mode, maybe why it can't be seen in virtualbox? Also my host is running Zonealarm firewall and Microsoft Security Essentials. In addition the guest has AVG antivirus. Could those programs conflict with virtualbox?

share|improve this question
    
Perhaps check your host machine's services list for some ipod helper service that you can disable.. Certainly try this while you've got iTunes closed too. I'm thinking your host machine's talking to the ipad before your vm host software can do anything with it. –  Doc Jul 4 '11 at 16:16
    
@Phil please use comments to add your comments about the answer, don't edit the answers. –  Sathya Jul 4 '11 at 16:54
    
it might be possible that the recovery mode is causing VB not to see the iPad –  Sathya Jul 4 '11 at 16:58
    
Is this a jailbroken iPad? Sometimes, they run extra services which might be getting picked up by your host OS. –  maxmackie Jul 4 '11 at 17:02
    
strangely I plugged in a working usb stick and put a filter on it...does not work either –  phil Jul 4 '11 at 17:03

4 Answers 4

This is a working procedure for iDevices so that they are visible to iTunes running in a Windows XP guest on an Ubuntu 12.04 LTS host:

  1. Install the "Oracle VM VirtualBox Extension Pack" to match your VirtualBox version. https://www.virtualbox.org/wiki/Downloads
  2. Ensure that your user account is in the "vboxusers" group. You may need to logout/login again to pickup the group change. In the worst case you may need to reboot.
  3. Connect your USB device.
  4. Confirm that you can see your USB device via the lsusb command.
  5. Confirm that you can also see your USB device via the VBoxManage list usbhost command. You cannot add a working Filter in VirtualBox until this is working.
  6. In VirtualBox, go to the Settings of your guest, USB section, and add a Filter for your USB device.
  7. Start your guest and confirm that it can see your device.
share|improve this answer
1  
the key is step 2. Add user to vboxusers. usermod -a -G vboxusers <youruser> –  albfan Jul 12 '14 at 23:51

Getting USB devices working is notoriously tricky with VirtualBox - but surprisingly it isn't too bad as long as you follow these steps:

1) Make sure you configure your guest with the proper USB filters. These can be done in the properties for the VM, under the USB section. You will want to add a filter for you iPad, which you can do easy enough with the plus button and let it fill in the details. The important step here is that you clear out ALL the fields except the Name, Vendor ID and Product ID.

2) At this point you need to shutdown the guest (if it is running), and reboot the host. I am not sure why, probably something to do with registering the driver or something wacky. Make sure you iPad is NOT plugged in at this time.

3) After rebooting the host, fire up the guest you have running and connect your iPad. With any luck VirtualBox will see the device and grab it before your host takes it over. If not, you can try to associate it, though chances are you need to repeat steps 1 & 2 and make sure you have the right values populated in the filter details.

It goes without saying that you will need the extensions pack installed to get the USB support.

share|improve this answer

I followed the same steps, and guest Windows(XP) was able to see the iPad as a camera device, but iTunes couldn't see the device. I doubted that it was because USB2.0 support wasn't enabled from the USB ports configurations of my virtual machine in VirtualBox.

I enabled it (USB 2.0 EHCI Controller checkbox under ports->USB) and had to install the VirtualBox extension package, and then it worked like a charm.

share|improve this answer

There are two editions of VirtualBox. The opensource version and the free (as in beer) but not opensource version. See http://www.virtualbox.org/wiki/Downloads for the list.

Only the close-source version has support for streaming USB devices from the host to the guest. Also, you will need VirtualBox Guest Additions installed on the guest to be able to use your device.

share|improve this answer
    
there's no concept of "editions" anymore. The previously PUEL edition is now available as an extension pack virtualbox.org/wiki/Downloads –  Sathya Jul 4 '11 at 16:51
    
My bad, Sathya's right. Either way you need the extension to have usb support. –  maxmackie Jul 4 '11 at 16:52
    
I have the extension pack already –  phil Jul 4 '11 at 16:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.