Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This might sound a little vague at first, but bear with me, it might also get interesting.

The setup is:

  • Servers behind tight firewalls with only port 22 open.
  • Web Based VPN client (juniper) which creates another interface on my computer with an IP on the server's network and green cards with the firewall for that one port.
  • My router, with a nat configured towards my own PC's (windows 7) port 1010
  • My happy putty forwarding my server's 22 to my localhost:1010
  • Firewalls and suff configured in order to allow my computer answer that port from the internet

So far, so good. Once everything is hooked up, I can try to open another ssh session to ServerUser@locahost:1010 and it will take me to the server no problem.

Now, when I try ssh to my public address, lets say, serverUser@, the connection will time out... (yes, I'm doing it from outside the computer connected to the VPN, namely my phone, via 3G).

I'm no network expert, so my first guess was that the guys developing the VPN client would have done something to prevent exactly what I'm trying to do... Still, I think its more likely that I'm wrong and I'm just missing some networking aspect of the problem.

Just to make sure, I installed OpenSSH and tried to connect to my own PC from the internet and it worked. So I think I can say I have no problem with my networking in that part.

I could put more information here if needed, I'm just not sure from where to start.. What you guys say?



I've been doing some testing and I found some interesting points. (by the way, sorry for the lack of methodology doing this, I just really don't know which thread to follow when it comes to networking).

  • This elusive VPN client installs a interface with metric 1
  • I cannot manually change the metric of the new interface (it will disconnect the client)
  • I have installed a sshd on my phone for simpler testing and found that once connected to the VPN I'm dipper trapped than I expected: can't get in or out from my computer if not related to the servers.
  • I connected my computer with 2 different ifs: ethernet and Wifi. After connected cant get out through either.

Hope it helps...

share|improve this question
Re "I cannot manually change the metric of the new interface" - not even by modifying the routing tables with route or netsh? That's where the metric goes anyway. – grawity Jul 4 '11 at 23:02
Nope.. The client seems smart enough to detect I'm trying to do some seneaky thing and disconnects it self. When it connects again, It resets the metric and wipes a) my routes, b) aparently gets rid of gateways for the other adapters.. oh and yeah, if I try to put back the gateways, it will also disconnect -_-.. sucks. – flpgdt Jul 5 '11 at 10:24
up vote 0 down vote accepted

The problem might be because most SSH clients, when doing port forwarding, only listen for connections on the loopback addresses, namely and ::1 ("localhost"). In PuTTY, enable "Local ports accept connections from other hosts" under ConnectionSSHTunnels.

You can try something like lft, traceproto, or tcptraceroute to find out which hop is blocking your SSH connection.

share|improve this answer
Is apparently something more obscure. While I do have it configure to accept connections from the outside (mind my comment about connecting to it from my phone), I've been doing some testing and there some dirty tricks at play here... Check out the update – flpgdt Jul 4 '11 at 22:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.