Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My problem might be a little bit weird but I couldn't find any solution on the Internet.

I am using Macbook Pro and running Mac OS X 10.6.8 Snow Leopard.

My keyboard layout is "Turkish QWERTY PC". My problem is that I can not type the special symbols being typed by using Alt(Option)+3 and Alt+4 key which are "#" and dollar sign.

I actually opened Key Viewer and typed Alt+3 combination and it says I typed "#" but I can't.

Is there any solution to fix this? Actually, I really wonder why more.

Thanks a lot.

share|improve this question
    
Wait just Option+3 and 4 or 1-0 as well? –  Vervious Jul 4 '11 at 23:21
add comment

migrated from stackoverflow.com Jul 4 '11 at 22:42

This question came from our site for professional and enthusiast programmers.

1 Answer

I found the problem. It was because I set the keyboard shortcut for "Arrow Keys to switch directly to a space" as "Alt(Option) Key + Number keys" in Spaces.app. I don't know why this caused a conflict but after I changed that setting to "Command + Number keys", it resolved.

Thanks again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.