Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After connecting from my home via remote desktop, both my screens are black when I arrive at work. The only thing I can see is a mouse pointer on one of the screens. I then seem to have only two choices: rebooting or working from a remote desktop connection, which works fine.

It did happen every time I tried last week.

However, I did the same from my laptop in a meeting room today, and I didn't have any problem.

share|improve this question

5 Answers 5

up vote 4 down vote accepted

I have had a similar issue. While not a fix this is the work around we found to avoid restarting: While one of you screens is black and not showing the mouse the log-in screen is actually there.

Use the keyboard to log into your account (we press Esc a few times, then ctrl+alt+delete, then enter password and hit enter) you will log in and the monitor that wasn't showing the mouse cursor will come back to life.

Again, just a work around I'm afraid but it saves a reboot or two.

share|improve this answer
2  
We've experienced the same thing. A user with RDP into their office desktop, main monitor is blank and second is awake (shows black with cursor) and hitting Ctrl+Alt+Del and entering in the password (if account is locked) will wake the machine. –  edusysadmin Jul 11 '11 at 2:29
    
After a little reading it looks like setting the display to not sleep after x minutes in the power settings (which our PCs are forced to by policy) can solve the problem. Will make myself exempt from that tonight and see what happens. –  Windos Jul 11 '11 at 2:39
    
Login screen isn't here, or not visible. ESC / Ctrl+Alt+Del / ... do nothing. –  ymajoros Jul 11 '11 at 9:25
    
The screen is there, the display is not awake to show it. If you were to go through the motions to login as if the screen were displaying in front of you it'd work. –  edusysadmin Jul 12 '11 at 0:43
    

I could eventually fix it by pressing WINDOWS-P and ENTER, to choose the active screen. The screen just appears after that.

share|improve this answer

There are a few issues and workarounds for this, so I will cover the most common cause of the problem (especially when connecting to Amazon Cloud servers):

  • for me it seems that disabling bitmap caching (1) solves the problem,
  • alternatively, as a manual work-around: forcing a full-screen redraw seems to help, to that end CTRL-ALT-END and then clicking Cancel, causes enough of a change in the cached bitmap to redraw in windows RDP.

Hope this helps, but let me know if you need any further info! :)

(1) Windows RDP Client Bitmap Caching Option

Untick the Persistent Bitmap Caching box to disable bitmap caching.

Where to set bitmap caching in windows 7 RDP

share|improve this answer

This fixes it:

Start Menu Edit Group Policy (not sure where it is at in the start menu, or if it is in the start menu, but the type to find worked) Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits Set time limit for disconnected sessions (set this to Enabled and make sure the option is set to Never end a disconnected session)

share|improve this answer

I just discovered that I could get around this issue by clicking on the login button (arrow icon) with the mouse rather than pressing the enter key after typing username and password. Hope this discovery helps others....

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.