Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm sorry if this landed on the wrong stack, I'm not entirely sure if this or serverfault would be more suitable.

I have a very strange problem, when I install any iRST driver newest or older ones my DPC Latency goes through the roof and as a result all my audio is crackling and popping, whenever some sound is playing.

My PC:

  • Windows 7 64-bit SP1
  • P67 Extreme4
  • Vertex 3 120GB
  • i5-2500K
  • Asus GTX 570 DIRECTCU II
  • Corsair 750W AXEU

I've done a complete reinstall of windows and tested with only the iRST drivers installed (10.1.0.1008)

My second (resulting) problem is, that without the iRST drivers my boot takes about 9mins and shutdown takes a few mins too.

With the iRST I have a normal 45sec boot up.

Edit: I should mention that the whole thing is brand new

*Edit2: * I've noticed some problem with my USB ports too. Not sure if it is related. It takes really long times for windows to load my USB devices, be it mouse or keyboard or HDD. In BIOS the jeyboard and mouse are recognised instantly. I've ran speed test on my USB HDD's and it reports ~33Mb/s so the ports shouldn't be malfunctioning.

share|improve this question
1  
Do all the capacitors in the system look healthy? –  Doc Jul 5 '11 at 15:33
    
Hmm, good question. I need to check on that, but I'm pretty sure there should be other problems if the caps were damaged. –  deiga Jul 5 '11 at 15:36
    
hard to say. Busted caps can cause really weird problems. Especially since they can still function somewhat. And parameters like heat can begin to factor in more. I wouldn't rule them out without a visual inspection. –  Doc Jul 5 '11 at 15:49
    
Yeah sure, I'll check them. Would be just my luck that a totally new Mobo had busted caps :D –  deiga Jul 5 '11 at 15:54
    
Well, thing about new hardware is that it may have a defect and thus was prone to fail very quickly. I figure after a few months of solid operation, you can rule out a manufacturing defect, in general. –  Doc Jul 5 '11 at 15:54

1 Answer 1

This is an old question but have you gotten a resolution? There have been a lot of releases of the Intel Rapid Storage Technology drivers since 10.1... so definitely try updating to the latest version.

10.8.0.1003

share|improve this answer
    
Ah, very nice. No I haven't found a resolution. But I will try the newest RST tonight :) –  deiga Mar 13 '12 at 13:04
    
Turns out that the new version is having the same problem. I'm really leaning towards some kind of hardware fault. –  deiga Mar 14 '12 at 9:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.