Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed Ubuntu 11.04 along with Windows XP. Grub is installed properly. When the grub menu loads I get a moving message window saying my monitor is not in the optimum resolution of 1280x1024 and 60Hz refresh rate. I can boot windows because I know it is the last item on the grub list. So, I just press the down key for a long time. If I don't press anything Ubuntu loads. I changed /etc/default/grub and added the line

GRUB_GFXMODE=1280x1024

and did an update-grub. This did not work. Please help.

share|improve this question
    
Wouldn't it be GRUB_GFXMODE=1280x1024 instead? –  Vervious Jul 5 '11 at 15:50
    
@Nano8Blazex: Sorry. Edited. –  Bruce Jul 5 '11 at 15:50
    
Btw, is this grub legacy or grub 2? –  Vervious Jul 5 '11 at 15:57
    
@Nano8Blazex: Grub2 –  Bruce Jul 5 '11 at 16:01

1 Answer 1

Interesting problem. Someone on this forum posted adding insmod vbe to their grub config did the trick for them.

The Ubuntu community documentation for Grub2 (which is the version of grub that comes with Ubuntu 11.04) should also help. The section here suggests that you can probe available resolutions from the grub prompt by pressing 'c' from the main grub screen and entering the command 'vbeinfo'. Since you're grub is where it's at, you may want to try this from the Ubuntu installation CD.

You could also try updating that parameter you gave to something like:

GRUB_GFXMODE=800x600x16

That way you're also declaring a colour depth. I'd like to think Grub would just default to something, but maybe not - or maybe the default's what's killing you.

Hope something in there helps ya.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.