Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm attempting to test out a piece of networking software that simulates delay between different network segments. In order to simulate the delays the software creates a bridge between two of its Ethernet ports with the specified delay. We've ordered hardware that this software (or some other software with similar functions) will be running on. However, it will be a few weeks before the hardware gets here and I need to know that the software that is chosen will work as expected. Hence I had the idea to make a virtual network with VM's using VirtualBox.

Right now I have 3 VMs: Client1 is on the first network segment, Client2 is on the second network segment, Channel Software sits between the two segments. I've configured the NICs of each VM using the following commands:

VBoxManage modifyvm client1 --nic1 intnet
VBoxManage modifyvm client1 --intnet1 seg1
VBoxManage modifyvm client2 --nic1 intnet
VBoxManage modifyvm client2 --intent1 seg2
VBoxManage modifyvm channel --nic1 intnet
VBoxManage modifyvm channel --nic2 intnet
VBoxManage modifyvm channel --intnet1 seg1
VBoxManage modifyvm channel --intnet2 seg2

When I put a set of IPs on the NICs in seg1 and a different set of IPs on the NICs in seg2 I can ping either segment from the channel VM. However, after setting the two clients to use the same IP network and bridging the virtual connections on the channel VM everything stops working. I've even tried assigning different IP networks to each client, just for the heck of it, but it doesn't work.

I was going to try using something a little fancier like VDE which has native support for VirtualBox. The problem is that if I want to use that I have to compile VirtualBox myself and it appears as if I have to run all of this on Linux. Normally that wouldn't be a problem but I only have access to a Windows machine at work.

I would like to know have I set something up wrong in the virtual network? If so what? If not do I have any alternatives to VDE or do I have to go meta and use VirtualBox to run a Ubuntu VM that runs VirtualBox with VDE and my client VMs?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I didn't realize that when I created the bridge it created an entirely separate interface. When I ran ifconfig -a I saw that it created a new interface. When I brought the interface up using ifconfig <bridge name> up Everything worked as expected.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.