Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After the weekend, certain programs on my computer have stopped functioning normally. Most important is Scrapy and Python which I need for a specific task. Now when I run Scrapy, I get an error. I tried uninstalling and re-installing but this problem persists. Please help. I am using Windows 7 (which I am required to use).

C:\Users\abc> scrapy -help
ImportError: No module named site

C:\Users\abc>python
ImportError: No module named site

C:\Users\abc>python -v



# installing zipimport hook

import zipimport # builtin
# installed zipimport hook
ImportError: No module named site

# clear __builtin__._
# clear sys.path
# clear sys.argv
# clear sys.ps1
# clear sys.ps2
# clear sys.exitfunc
# clear sys.exc_type
# clear sys.exc_value
# clear sys.exc_traceback
# clear sys.last_type
# clear sys.last_value
# clear sys.last_traceback
# clear sys.path_hooks
# clear sys.path_importer_cache
# clear sys.meta_path
# clear sys.flags
# clear sys.float_info
# restore sys.stdin
# restore sys.stdout
# restore sys.stderr
# cleanup __main__
# cleanup[1] zipimport
# cleanup[1] signal
# cleanup[1] exceptions
# cleanup[1] _warnings
# cleanup sys
# cleanup __builtin__
# cleanup ints: 6 unfreed ints
# cleanup floats
share|improve this question

migrated from stackoverflow.com Jul 5 '11 at 17:16

This question came from our site for professional and enthusiast programmers.

    
Have you run chkdisk (or fsck on linux) and checked the SMART logs for hardware errors? – Ex Umbris Jul 5 '11 at 16:07
    
Ex Umbris, could you elaborate? I am not familiar with chkdisk or SMART logs. – user88969 Jul 5 '11 at 18:15
    
Run set and post the contents of the PYTHONPATH variable. That error usually indicates that Python can't find the directory it stores its libraries in. – Patches Jul 5 '11 at 19:29
    
What is the output from running '%PATH%' and '%USERPROFILE%' on the command line? This looks like an issue of the path not being set correctly or the user directory not being defined correctly. – Sion Jul 5 '11 at 19:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.