Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My operating system is Mac OSX Leopard, but I am using a non-Mac, two-button mouse. How do I enable the left button to automatically open files with a double click?

share|improve this question

2 Answers 2

The left button should work that way automatically; USB and Bluetooth mice use a standard interface that works the same everywhere.

share|improve this answer
    
It was working and just stopped. Now I have to double click the file, then right click to get a flyout menu with open file. Frustrating! –  Von Gordon Jul 5 '11 at 17:32
1  
In that case, you may want to go into System Preferences > Mouse and see if adjusting the double-click speed helps; if it's set too fast then you may have trouble getting a double click to be interpreted properly instead of as two single clicks. –  geekosaur Jul 5 '11 at 17:43

It sounds as though there may be a problem with your mouse as opposed to an issue in the OS. I've seen it before as mice get older the buttons will begin to stick in the "down" state and therefore not register a click properly. You could try cleaning around the buttons as best you can, or even just try pulling up on them ever so slightly (not enough to break the button off obviously). This may release them enough to register clicks properly once more. Depending on the cost of the mouse, it may be easier to replace it with another one.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.