Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Can't open a folder in windows 7 64bit, by double clicking, it shows me that the default option for opening folder is "cmd" (it's highlighted when i'm right clicking a folder, and the "open" option comes next). I've tried running some registry fixing tools, but it didn't fix it. Can someone suggest me what should I do.

share|improve this question

migrated from stackoverflow.com Jul 5 '11 at 19:46

This question came from our site for professional and enthusiast programmers.

4 Answers 4

Set HKEY_CLASSES_ROOT\Folder\shell\(default) to an empty string.

share|improve this answer
    
It's already an empty string. I've chnged it anyway and it didn't help? –  RCB Jul 5 '11 at 21:55
    
What subkeys do you see? What about HKEY_CLASSES_ROOT\Directory\shell\(default)? –  SLaks Jul 5 '11 at 22:13
    
under Folder-> Shell i have only the default, I also have other sub directories : explore, open, opennewprocess, opennewwindow. under the Directory->shell there is also only default & sub directories : cmd, find –  RCB Jul 6 '11 at 6:27

I've solved it simply by renaming the folder. I could access 99% of folders but for some reason one or two wouldn't open. Only downside is, if I rename it to what I had before, again the folder doesn't open.

share|improve this answer
up vote 0 down vote accepted

Yeah !!! Solved it!!!!

in the regedit I've entered to the HKEY_CLASSES_ROOT\Directory\shell\, there was a sub directory called cmd I've deleted it and now everything works fine.

I think it didn't do any other unexpected damage, I've been using my computer for several hours and it seems there are no unwanted side-effects


An anonymous editor mentioned that deleting subdirectories might not be necessary, he rather solved it by changing the value of (default) to explore (which picks up the explore subfolder instead of the cmd subfolder).

share|improve this answer

SOLVED! First thing, it is not necessary a virus. Do not spend hours looking for malware or virus if you already have an antivirus installed.

This problem happend to me after a Windows Update. The first time I had identified the culprit to "Update for Windows 7 for x64-based Systems (KB2952664)" that time after two days I only solved the problem by recovering windows to a previous update prior to that above. From then on I installed windows updates one by one until it happened again.

The second time Windows Update did it but this time I could not recover my system to any prior time, it would stuck at any point the system recovery and return, after re-starting, to the stage that it does not open the folders, then even worst, the log of all previous updates was empty. For some unknown reason it disappeared.

After trying everything at reach and tens of suggestions from everywhere in the internet for two weeks the above suggestion solved the problem for my system Win7 Pro 64 but with an extra step.

Open regedit and change the '(default)' value to 'explore' in the next two lines (no quotes marks)

HKEY_CLASSES_ROOT\Directory\shell\

HKEY_CLASSES_ROOT\Folder\shell\

I did it to only one of them separately and did not work. Only when both lines are changed to 'explore' solved the problem. I hope it helps.

share|improve this answer
1  
Welcome, and thanks for the input. Two things. 1) Just FYI: normally, clarifications or minoir modifications to an answer would be done with a comment rather than a new answer. However, this post would be too long for a comment and you need a little more rep for that, so that's just for future reference. 2) Answers change their display position, so "the above suggestion" is ambiguous as to what you're referring to. It's better to identify the post by the author's name. –  fixer1234 Jul 8 at 4:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.