Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having a problem with one of my USB devices (a 3G modem). In order to make it work with my router, I had to log into the device using Terminal's screen command and disabled the software CD from being mounted, which worked fine.

However, I've had trouble with my computer and had to reinstall everything and now I can't install the software because the "built in software" isn't showing up on Finder due to my earlier actions.

The device is recognised by my Mac, but I can't access it via screen /dev/cu.ZTEUSBModem any more, its name must have changed.

How do I find this name? There're a lot of "ttyw1 (or a different number)", but none I recognise.

share|improve this question
    
It'd help if you told us what you did before to "disable the software CD". Also, can you spot anything in /dev? (Do a ls /dev and look for something related to your modem) –  slhck Jul 5 '11 at 21:02
    
Sorry, I'm typing on my iPad...I called a command specific to the modem. Ls/dev returns a long list of unrecognisable names - ttyp0, ttyp1 and so on. In "About this Mac", the device is recognised, but it doesn't tell me the name of the interface either. –  Prypiat Jul 5 '11 at 21:06
    
Hm. Open your System Profiler (alt + ) and select the modem. Can you spot a "BSD Name"? It should start with /dev/cu* though. –  slhck Jul 5 '11 at 21:12
    
No. The cu name was there with the drivers installed, but isn't now. The device however does turn up in the "USB Section" with a plain English device name. No BSD name though. –  Prypiat Jul 5 '11 at 21:18

1 Answer 1

up vote 2 down vote accepted

If you do ls /dev/cu.* and still don't see anything that looks like your ZTE modem, then you'll need to download a driver for your modem from elsewhere. Mac OS X does not have universal drivers for USB serial drivers (does that exist in any OS?). USB serial device drivers are some of the few things you always have to go find and download and install on Mac OS X.

They have a support site that I've used. It's poorly translated into English and poorly designed, and you have to register a free account to use it, but I was able to use it to find most of what I was looking for. They also have a free live support text chat widget, and I was able to get help from a support rep with passable English.

share|improve this answer
    
It used to show cu, with the drivers installed that is. –  Prypiat Jul 5 '11 at 21:15
    
@David Yeah, to access the serial-like capabilities of that USB device, you'll need to load a serial driver specific to the USB serial chip that's in it. You'll need to get those drivers elsewhere. –  Spiff Jul 5 '11 at 21:26
    
Their website is broken and won't let me register - do you have the driver by any chance? –  Prypiat Jul 5 '11 at 21:26
    
@David Unfortunately I don't. –  Spiff Jul 5 '11 at 21:55
    
Fixed it by downloading the drivers and taking apart the broken installer. :) –  Prypiat Jul 6 '11 at 9:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.