Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had Drive Genius installed some time ago and I still have an option in the context menu (Drive Genius Secure Erase) that came as a feature with that software. Unfortunately, though I have uninstalled the software, the option is still there.

Is there any way I could remove that?


share|improve this question
OS X Snow Leopard? – Vervious Jul 5 '11 at 21:52
Yes, it's 10.6.8 – Mihai Neacsu Jul 5 '11 at 21:58
up vote 1 down vote accepted

There are probably some left over files when you dragged Drive Genius to the trash. Some programs do not store their data in a manner that allows additional app files to deactivate.

Use TrashMe to remove any orphaned files or left over data related to Drive Genius.

share|improve this answer
I used AppCleaner, which I think is similar. – Mihai Neacsu Jul 5 '11 at 22:20
In addition, you may want to try TrashMe. It has some extra utilities and search methods. – evan.bovie Jul 5 '11 at 22:23
Just rebooted and it worked! Thank you, sir! – Mihai Neacsu Jul 5 '11 at 22:26

From someone who actually also was experiencing this problem who came here for help on this as well, I found that Indrek's solution was the only workable one for me.

Drive Genius does not place files in ~/Library/Contextual Menu Items which is where you would expect to find something like this.

Here is what worked for me to remove the Drive Genius 3 contextual menu item

  1. Delete the application
  2. Remove /Library/Application Support/Drive Genius
  3. Reboot

I had tried deleting preference files and other seemingly related files and rebooting and that did not have an impact on this problem.

Also note: To get rid of other useless files and effects left by this program after you shut it off in all its settings (which it may ignore) and it still leaves behind the system pull down menu extra icon that goes near the clock, I find that removing all three "prosoft" and "Drive Genius" items it tucks away into /Library/LaunchAgents and /Library/LaunchDaemons such as the definitely secure-deletion-related "com.prosofteng.DriveGenius.locum.plist" file and rebooting wipes that after-effect out as well.

share|improve this answer

You could try to emulate Rene Larsen's solution from a previous question on the Apple Stack Exchange site:

I've just installed and then uninstalled iconStiX again - just to see where the stuff was placed.

The uninstall is like this (see Readme.pdf in iconStiX.dmg):

Throw away the following 4 items into the Trash:

  • the iconStiX program in your Applications folder (or any other place of your choice)

In your ~/Library/Preferences:

  • li.loos.trollin.iconStiX.plist
  • li.loos.trollin.iconStiX.LSSharedFileList.plist (if any)
  • a folder named iconStiX in your ~/Library/Application Support folder

Empty the Trash.

BUT this doesn't remove the Contextual Menu Items - unless you reboot your Mac (I did that, and the items was gone).

share|improve this answer

I've had the same problem. I solved it by deleting the /Library/Application Support/Drive Genius folder. Both Drive Pulse and Secure Erase are now gone.

share|improve this answer

There could be some files left in ~/Library/Services/, /Library/Services/, ~/Library/Contextual Menu Items/, or /Library/Contextual Menu Items/.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .