Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I own a Nikon camera which I use with a Transcend 16 GB SDHC card. The camera possesses a built-in formatting tool and everything just works, and I am able to take pictures and they are saved to the card.

I bought an SDHC card reader which worked just fine until today. I don't know what happened, but as soon as I plug in the card reader with the SDHC card Windows prompts me and says the card need to be formatted. Fine, I format. Then I get an error, Windows cannot format the card. I tried different formatting solutions:

  • OpenBSD fdisk. I can write a new MBR which has an entry to the 64th block until the end of the disk, marked as FAT32. However, as soon as I write and exit fdisk, it's erased, the pid is now the pid of a weird filesystem (always the same), so I don't have any "Windows like" partition created to write my filesystem.

  • Backtrack fdisk. Somewhat the same problem, it works and when I launch it again to check the settings, it's back to the old empty screwed up partition table, so it asks me if I want to re-partition it again.

  • SDFormatter. Fails with a "cannot write, remove the write protection"- like message, the write protection is of course turned off (I even tried with a tape...), it's marked off in Backtrack's DMESG, and I've tried to turn it on to check the difference. It's different indeed and proper tools report a write-protection error. Nothing really helpful...

  • AutoFormat (from Transcient). Surprisingly, it reported success. However, the card is still unusable from Windows (same error) and from the camera... Epic fail.

I've come to suspect the USB card reader, although the reviews are good on the net, and it worked yesterday... I've tried with another perfectly new SDHC card, same issues, no difference. Both cards work with the camera, but Windows fails to recognize it, the file system is not recognized.

I've tried 3 different computers, with different windows/GNU/Linux/*BSD version.

From what I understand it looks like the card reader is broken, but it doesn't make any sense for it to break like that...

How can I fix this problem?


It's the OP. I've bought an USB cable, and it works fine. It looks like the cheap USB SDHC card reader failed. I'll have to buy a proper one.

share|improve this question
    
Well, if you suspect the reader, I guess you don't have a different one handy as you would have just tried that, right? I'd probably go to a Walmart or something and see if the card can be read by a reader on a computer left out on the floor.. –  Doc Jul 5 '11 at 21:47
    
Correct, I don't have another SDHC card reader :(. I will go to a computer shop tomorrow and try to plug my card in a demo computer's embedded reader. –  Aki Jul 5 '11 at 22:19

1 Answer 1

up vote 0 down vote accepted

It definitely sounds like a broken card reader. You could try connecting your camera to your computer via USB, this should allow you to access the card via the camera's built-in card slot. If this works fine, then it's almost certainly the card reader. It is odd for it to fail that way, but so it goes.

share|improve this answer
    
I see. Of course the camera didn't come with such a cable, I'll buy one tomorrow along with a new card reader and let people know. Thanks for the suggestion. –  Aki Jul 5 '11 at 22:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.