Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here is the setup:

Cable Modem -> Vonage "Router" (not really sure if it is a full router or not) -> Linksys Router -> Netgear Switch -> PC

When I had the PC connected directly to the router I could route to it just fine. When I put it behind the switch I no longer can.

Pardon my obvious lack of knowledge on this, but is there some way to route to the PC behind the switch or do I have to reconfigure the network somehow (eg: replace the switch with another router, reconnect it directly to the router, etc.)

If specific model names\values are needed I can provide them, but I believe this to be a general topic.

UPDATE #1

I completely removed the vonage device and I switched the PC to non-static ip, yet, I can not even connect to the local ip address from anywhere on the LAN. I am beginning to think it is a firewall or anti-virus problem.

EDIT #1

By "route to it" (the PC in question) I mean access ports running on said PC remotely. eg: port 80, 22, etc.

EDIT #2

The strange thing is, to get things to work (before) I had to config the vonage device to route to the router (which I had to hunt down it's local address) and then also route to the PC from the router as well. Additionally, I have the PC setup with a static IP as to prevent the address from being reassigned.

EDIT #3

I tried turning DHCP & NAT off at the router. With DHCP off I still have an outbound connection but the default gateway still shows up as the router and I still can't connect from external. When I turn NAT off I get no connection at all. I believe I used to have "double natting" working by routing traffic from the vonage device to the routers address, and then router to PC - but this no longer seems to work and I have no idea why. Furthermore, I can reach the router but NOT the vonage device from a browser - I find this highly suspect, but I have no idea what the cause.

Any other suggestions out there?

EDIT #3a

Removing the static IP config allows me to connect to the vonage device - not sure if that will help someone else, just throwing it out there.

share|improve this question
    
What do you mean "you could route to it" Route what from where? –  uSlackr Jul 5 '11 at 22:23
    
edited to answer your question –  javamonkey79 Jul 5 '11 at 22:25
    
Hmmm... You shouldn't have any troubles, as a switch does not do NAT. What is the model of the Netgear switch? Also, what does your Network Connection Status say? A screenshot might be easiest. –  evan.bovie Jul 5 '11 at 22:26
    
Wait, what is the local IP address of your computer? I bet that when you put your computer through the switch, it changed your PC's IP address. Check that against your router's port forwarding settings. –  evan.bovie Jul 5 '11 at 22:28
    
What sort of screen shot would help? I set it up to have a local static ip, when I run ipconfig it is consistent with the assigned address. –  javamonkey79 Jul 5 '11 at 22:44
show 3 more comments

3 Answers

up vote 2 down vote accepted

Unless you really know what you're doing, you only want one box acting as a NAT gateway and DHCP server on your home network. When most people say "router" in the context of a home network, they're actually talking about something that's acting as a full NAT gateway, not a simple IP router.

I'm sure your Vonage box does NAT and DHCP. Also, it makes sure that your voice traffic gets the priority it needs when forwarding it to your broadband connection (i.e. your cable modem). But the Vonage box can only do that for your voice traffic when it's at the head of your network.

So, for best results, make sure your cable modem and your Linksys router are not serving NAT and DHCP. Have the cable modem simply bridge between Ethernet and cable, and have the Linksys box simply bridge between LAN and WAN.

If the Linksys box doesn't provide a way to turn NAT off, then turn its DHCP server off and stop using its WAN port -- just plug one of its LAN ports into the LAN side of the Vonage box. This allows the Linksys box to still act as a Wi-Fi access point (assuming that's what you're using it for -- if you don't need it, then take it out of the picture), and it acts as an Ethernet switch among its LAN ports.

With any NAT gateway, if you want it to forward incoming connection attempts from the outside world in to some host on your LAN, you'll have to set up port mappings in the NAT gateway to tell it which next-hop IP address and port to forward that kind of connection attempt to. If you set up your network with multiple NATs, then you have to tell each NAT about the next-hop NAT gateway, which is a pain and is one of the reasons you should avoid "double NATting" unless you really know what you're doing and have a good reason to do so.

share|improve this answer
    
What an awesome answer!!! I will try your suggestions and get back to this post. –  javamonkey79 Jul 6 '11 at 1:12
    
I added an edit above to answer this. –  javamonkey79 Jul 6 '11 at 16:15
add comment

I know what Vonage says about putting it before the router, but I have set this up before and I simply go with this:

Cable Modem--Linksys Router--Netgear Switch

The Vonage box and PC get plugged into the switch.

If this normal, and simple setup does not work, then you can try it their way, but every one I have done has worked. Only caveat, I usually use a Netgear router/switch combo.

share|improve this answer
    
Yeah, I think I had some trouble when trying to put vonage behind the router but I can definitely try again. –  javamonkey79 Jul 5 '11 at 22:46
    
This sort of setup might require QoS to be setup on the Linksys to prioritize the voice through it. The vonage device does this already, but if it is going through another router later, it might not be as effective. –  MaQleod Jul 7 '11 at 4:46
add comment

Even though I have accepted an answer (because it answers what I was asking); the real source of my problem was a change in the Windows firewall settings - I believe this occurred with an automatic update from MS.

I hope this helps someone else.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.