Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 2 computers running Windows 7 Professional that are part of the same workgroup. Password protected sharing is turned ON. On both computers, i have a single user. These two accounts have the identical names and identical passwords. Example:

PC1: User1 (name="ABC", password="DEF")
PC2: User2 (name="ABC", password="DEF")

Here is my problem. I go on PC1 and right click a folder and go to "Share with" > "Specific people". In the list, there is only myself (ABC). I do NOT add any new entry. I simply click Share and the folder is shared successufully with myself (\PC1\ABC). Now, if I go onto PC2, I see the shared folder, but I can't connect to it ("Windows cannot access \PC1\folder..."). Troubleshooting the problem returns "Your user account doesn't have access to \PC1\folder".

But If instead I share the same folder from PC1 with Everyone, then it becomes accessible from PC2. But this way, anyone on the workgroup can access it...

Since my account on PC2 has the same name and password, it should work right? Otherwise, why would Windows allow me to share a folder with myself?


EDIT: I've done some more testing. I've found that these 2 conditions must be respected in order to have the folder accessible from PC2:

1) The folder must have read permission for Everyone (Properties > Security tab)
2) The share must have read permission for Everyone (Properties > Sharing > Advanced sharing > Permissions)

Removing Everyone in any of these 2 cases and replacing with Administrators or \PC1\ABC renders the folder not accessible from PC2.

I've also trying switching the folder owner between Everyone, Administrators and \PC1\ABC without any success.

share|improve this question
    
A similar question was asked in the past, but the answer does not help me: superuser.com/questions/113344/… –  bouvierr Jul 6 '11 at 2:21
    
have you created a homegroup yet....howtogeek.com/howto/windows-7/… –  Moab Jul 6 '11 at 2:39
    
There is Sharing permissions and there is Folder permissions, check the folder permissions. –  Moab Jul 6 '11 at 2:40
    
This is why homegroup rules. . . –  surfasb Jul 6 '11 at 5:38
    
If password protected sharing fails on the workgroup, I will resort to using homegroup and linked ID. However, I am still interested in understanding the described problem. –  bouvierr Jul 6 '11 at 17:04
add comment

2 Answers

up vote 1 down vote accepted

SIDs(Security IDs) are the (greatly simplified) reason More info

PC1\ABC has the {example} SID of S-1-5-21-1106717361-1361586587-285947020-501238
PC2\ABC has the {example} SID of S-1-5-21-2533013469-2641548184-613786714-651000

As they are not the same, when ABC from PC2 gives their credentials, PC1 simply says You are not who I think you are. Access Denied
If the passwords/IDs do not match, then PC1 will ask for identification, and will allow connection as the PC1 user when the correct info is entered.

share|improve this answer
add comment

the "net" command. Not to say it's a good fix, but it sometimes is the only way I've found to connect to shares without explorer picking all the options.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.