Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Environment:

OS: FreeBSD 8.2 64 bit

GNOME: I don't know how to check gnome's version in console. I install it from the latest port collection via internet.

Issue:

Each time I boot the OS, it display the login window. And I input my username and credential, then it begin to login, and I can see the desktop has been displayed, and I also see some icons in the desktop. Suddenly, the user is logged out automatically and back to the login window.

I've tried both common user and root, neither works.

I've mount the proc file system.

I've enable gnome in rc.conf

I've add '/usr/local/bin/gnome-session' to the ~/.xinitrc

I'll be very grateful if you can give me any suggestion. Thanks.

share|improve this question

1 Answer 1

In your .xinitrc, make sure that the last command (probably gnome-session) does not end with an ampersand (&). If that's the case, the .xinitrc will finish, and GDM will respawn the login screen. At least it used to be this way.

Otherwise, try with KDE or other WMs (like twm) instead, and see if they behave differently. That could give you a clue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.