Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am sharing a folder in Windows XP; and all the computers are part of the same workgroup. I attempt to access the share on Windows 7 and I am prompted for a password. How do I disable password protected sharing on Windows XP? I am NOT using simple file sharing in XP.

share|improve this question

4 Answers 4

You cannot disable the password requirement. As you said yourself, you have "simple file sharing" disabled, which means that all incoming connections to the XP computer will require authentication.

If your account has the same password on both computers, you should be logged in automatically, without any prompt. Otherwise, you can store the XP password in "Credential Management" in Win7. (However, if the password on target PC is blank, the default configuration for Windows is to disallow any logons over the network, and allowing that would be plain stupid.)

share|improve this answer
    
Does being in a domain affect this? If I create a share on windows xp box and give everyone permissions I can access it without a password... maybe because they are both domain members? –  Kyle Jul 6 '11 at 18:56
    
@Kyle: Like I said, "if your account has the same password on both computers"...in other words, Windows automatically tries to connect using the credentials you logged in with; whether it's a local or domain account doesn't matter. (But yes, being in a domain affects this in a way: "simple file sharing" is always off and cannot be enabled.) –  grawity Jul 6 '11 at 19:08
    
Oh, okay so even if I create the share as administrator and give permission to only everyone, then access it as Kyle it will still use my credentials? .....never realized that's the way it worked... I thought everyone meant "everyone". –  Kyle Jul 6 '11 at 19:12
    
@Kyle: Everyone does mean everyone in a way: every authenticated user, whether BUILTIN\Guest or a local/domain account. This excludes anonymous connections. There is a setting "Apply Everyone permissions to anonymous users", but I don't know how it affects SMB connections. Even if it does, the client will attempt authentication in SMB before opening the share and having the server-side permissions tested. (I'm not 100% sure about this, though.) –  grawity Jul 6 '11 at 21:03
1  
The "everyone" share permission is depreciated. Microsoft keeps it in there because drives formatted with FAT don't support a lot of file level security. On domains and NTFS drives, Microsoft recommends you give full share access to everyone and use NTFS security for the files. –  surfasb Jul 6 '11 at 22:36
  1. Go to start and go to run and type in secpol.msc
  2. Go to Local Polices -> Security Options
  3. Change Accounts: Guest account status to Enabled

Check to see if that works.

Other settings to check are

  • Network access: Do not allow anonymous enumeration of SAM accounts and shares Set that to disabled.
  • Network access: Let Everyone permissions apply to anonymous users set that to enabled.
share|improve this answer
    
+1: Thanks, this actually helped me to, on the contrary, re-enable password request on WindowsXP pro hosts. It seems now the guest account is enabled by default on clean install + full updates installed. –  ceztko May 9 '12 at 16:28

Right click the folder you are sharing and click properties. Then navigate to the sharing tab, you should see a permissions button add everyone and tick the full control check box. This will then allow anyone on the your internal network to access that share. If you want some modest security through obscurity here just add a "$" sign to the end of the share name. People can still find the share but it's not as easy as just browsing the network and requires software.

share|improve this answer
    
I already have this setting set; I'm beginning to think that XP doesn't interface well w/ Windows 7 –  nobody Jul 6 '11 at 16:00
    
@nobody - When the password prompt comes up do you have to enter anything or can you just click OK? –  Kyle Jul 6 '11 at 16:13
    
@nobody also what does the security tab say? –  Kyle Jul 6 '11 at 17:23

You need to setup sharing access AND filesystem access for this to work.

  1. In the folder properties, in the Sharing tab, you can configure sharing and set permissions.

    If you're on a domain, or if you're using the same username AND password on every machine, you can give the access to Users. Otherwise, you can use Everyone.

  2. However, you may also have to setup NTFS permissions. A remote user has at most the sharing permissions you set up on the shared folder but is still restricted by NTFS permissions. So, in the Security tab, add read-write permissions (or read-only if that's all you need) to the same group you used in the first step.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.