Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It always has this problem.

--> Finished Dependency Resolution
perl-AnyEvent-5.240-1.el5.rf.noarch from rpmforge has depsolving problems
  --> Missing Dependency: perl(Net::SSLeay) >= 1.33 is needed by package perl-AnyEvent-5.240-1.el5.rf.noarch (rpmforge)
Error: Missing Dependency: perl(Net::SSLeay) >= 1.33 is needed by package perl-
AnyEvent-5.240-1.el5.rf.noarch (rpmforge)

 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

I tried to install perl-AnyEvent-5.240-1.el5.rf.noarch.rpm

But it cannot be fixed.

[root@hosted-by pear]# rpm -ivh perl-AnyEvent-5.240-1.el5.rf.noarch.rpm 
error: Failed dependencies:
        perl(EV) >= 3.05 is needed by perl-AnyEvent-5.240-1.el5.rf.noarch
        perl(Guard) >= 1.02 is needed by perl-AnyEvent-5.240-1.el5.rf.noarch
        perl(JSON) >= 2.09 is needed by perl-AnyEvent-5.240-1.el5.rf.noarch
        perl(JSON::XS) >= 2.2 is needed by perl-AnyEvent-5.240-1.el5.rf.noarch
        perl(Net::SSLeay) >= 1.33 is needed by perl-AnyEvent-5.240-1.el5.rf.noarch
share|improve this question

migrated from stackoverflow.com Jul 6 '11 at 16:46

This question came from our site for professional and enthusiast programmers.

    
Did you try using the suggest package-cleanup ? –  Simon Sheehan Jul 6 '11 at 16:49
add comment

1 Answer

This sounds like the suggested fix at http://mattdanger.net/2010/12/perl-net-ssleay-dependency-error-when-installing-memcached-with-yum/ would help.

But I'm not an rpm user, so be careful.

share|improve this answer
    
I followed these setps , but it still can't be fixed .[root@hosted-by pear]# rpm -ivh perl-AnyEvent-5.240-1.el5.rf.noarch.rpm error: Failed dependencies: perl(EV) >= 3.05 is needed by perl-AnyEvent-5.240-1.el5.rf.noarch perl(Guard) >= 1.02 is needed by perl-AnyEvent-5.240-1.el5.rf.noarch perl(JSON) >= 2.09 is needed by perl-AnyEvent-5.240-1.el5.rf.noarch perl(JSON::XS) >= 2.2 is needed by perl-AnyEvent-5.240-1.el5.rf.noarch perl(Net::SSLeay) >= 1.33 is needed by perl-AnyEvent-5.240-1.el5.rf.noarch –  Smilence Jul 6 '11 at 16:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.