Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem where my Vista machine will not return from sleep or hibernation. This made me realize I have no idea of the mechanism involved. Searching has bought no results.

Could this be a corrupted registry? Or a problem with a file entry somewhere?

share|improve this question
1  
You need to provide more details. Does the resume not boot? Does it crash? You some function not work? –  dtech Jul 6 '11 at 18:20
    
Definitely sounds like hardware. Especially since the boot never gets to the OS in the first place. Does this happen everytime you turn off/sleep the computer? –  surfasb Jul 6 '11 at 20:14

2 Answers 2

The mechanism is called ACPI and theres already a good explanation of it on this thread, however your sleep problem may be your graphics card driver, download the latest driver from the graphics card manufacturer website eg www.nvidia.com , I'm guessing its a nvidia card. Ive had a few Dells and they don't always have the latest driver on their site.

share|improve this answer

I cannot help with the specific problem right now, but to answer the general main question, "What is the mechanism that Windows machine 'knows' it is returning from sleep or hibernate?", I can answer that.

Computers use the "Advanced Configuration & Power Interface", which is a combination of computer hardware, firmware and driver software to handle power management, and that includes sleeping and hibernation.

http://en.wikipedia.org/wiki/Advanced_Configuration_and_Power_Interface (of particular interest to your question is the section "Power States")

http://www.acpi.info/

Here in an in-depth guide regarding computer power management:

http://eetd.lbl.gov/EA/Reports/39466/

share|improve this answer
    
For more on your specific problem, you will need to post more inforation about what it is doing, how it is acting, etc. –  KCotreau Jul 6 '11 at 18:29
    
What occurs upon attempted resume is fan noise and cd drive noise. The laptop display remains off and no other keys/buttons are functional. The only thing I can do is hard power down. After perhaps 10-20 attempts to resume by powering down and retrying ( along with removing and reinserting the battery and other things I have no idea if helping or not) the computer eventually starts up- although it is usually a cold boot. –  user72058 Jul 6 '11 at 18:41
    
These are always hard to say for sure, but it sure does sound like faulty hardware. Was it working, then all of a sudden, with no system changes (updates, etc.), it started doing this? You don't say who makes your system, but see if they have a hardware diagnostic tool and run it. –  KCotreau Jul 6 '11 at 18:50
    
I've considered this could be a hardware issue, but what type would it be? The machine will cold and warm reboot flawlessly. This is the only issue I have with the machine. It is a Dell XPS1530 and it has passed their diagnostic suite with no issues. –  user72058 Jul 6 '11 at 18:56
    
Well, you probably ruled hardware out if it passed their diagnostic. You definitely checked the memory? I might also consider downloading the Ultimate boot CD and run the memory tests on it too: ultimatebootcd.com/download.html. Sleep and hibernation modes are basically a method of storing what is currently in memory, so that is especially critical. So it happens both on sleep and hibernation? Did it work at one time? I would also make sure that I had all the latest drivers installed for your model. –  KCotreau Jul 6 '11 at 19:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.