Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a flash drive which I dd'd a build of Chrome OS onto, and now I cannot format, mount, or boot the drive. I have tried using Disk Utility on:

  • Snow Leopard: (POSIX reports: The operation couldn’t be completed. Cannot allocate memory)

  • and using "Computer Management" on Windows XP (Stops at "Formatting: 100%").

How can I fix this flash drive?

share|improve this question
    
Please detail what happens (error messages, etc.) when you attempt to format it. – LawrenceC Jul 6 '11 at 18:48

In Windows, right click (My) Computer, click Manage and go to Disk Management and see if you can wipe and/or format the drive from there. This solves most problems, but if you're still stuck, leave a comment and I'll see what other options there are. :)

If none of the tools is able to format the drive, it's possible that the drive is just faulty. In that case you're best of just getting a new one.

share|improve this answer
    
That didn't work... it stops at "Formatting: 100%" – jburns20 Jul 6 '11 at 19:09
    
Try burning a Live CD of GParted and formatting it from there, it's got me out of a few binds in the past: gparted.sourceforge.net/livecd.php – Ruairi Fullam Jul 6 '11 at 19:13
    
I actually tried that and it wouldn't boot - AND it could have been the reason I had to reinstall my OS! – jburns20 Jul 6 '11 at 19:19
    
I think what I'd resort to using would be this: hddguru.com/software/2006.04.12-HDD-Low-Level-Format-Tool - after which I'd try to use Disk Management again. Can I just check though, have you tried other USB ports at all? – Ruairi Fullam Jul 6 '11 at 19:28
    
Yes, I've tried multiple USB ports. I'll try the HDDGuru. – jburns20 Jul 6 '11 at 20:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .