Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have encountered a very strange behavior in Windows 7 that I cannot seem to identify and I have never seen or heard of on any system configuration. Whenever I move my mouse to the left-most edge of my primary display (centered in 3-display setup), my desktop icons magically move away from the cursor (up or down and to the right). It only happens when my desktop has focus and the mouse is positioned on the left, top or bottom edge of the main display. Moving the mouse all the way to the right edge of my right secondary display causes the mouse icons to snap back into their correct position.

Ridiculous video of the issue

My setup is 3 displays on two display adapters. The main display is running at 2560x1600, connected to the machine via a USB-powered DVI-D to DisplayPort adapter and is driven by an NVIDIA NVS 3100M video card. The secondary displays are running at 1440x900 and 1200x1920 and are driven by integrated Intel HD Graphics (mobile).

It seems like some kind of panning behavior, but it's obviously not working as expected. I have updated all of my drivers, but no change. It's probably worth noting that the desktop icons are set to auto-arrange.

share|improve this question
1  
hahahahahaha! Funniest thing I've ever seen a computer do. But seriously, I hope you fix this. –  maxmackie Jul 6 '11 at 23:10
2  
Some would consider this a Windows "Feature", I wish I could make mine do it, awesome! –  Moab Jul 6 '11 at 23:18
    
That is brilliant - once you figure out the cause can you post on here so I can make mine do it:-) –  Rory Alsop Jul 7 '11 at 9:30
    
+1 Do you have any display ports set up? If the the viewable area is smaller than the desktop area you will get similar behaviour. But that wouldn't explain the background image remaining fixed –  Tog Jul 7 '11 at 12:29
    
@Tog No display ports that I'm aware of. I haven't configured anything of the sort. –  Nathan Taylor Jul 7 '11 at 15:27

1 Answer 1

up vote 12 down vote accepted

Is your notebook a ThinkPad? I had the same behaviour and it seems to have disappeared after disabling the "Auto Scroll Feature" in the "On Screen Display" tab of the monitor settings.

share|improve this answer
1  
Nice! Thanks buddy. :] –  Nathan Taylor Jul 8 '11 at 18:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.